0

I've set up Samba on my virtual machine and can perfectly access it through my Mac. However, when I try to access it through my Windows 10 installation by adding the following network location smb://192.168.x.x, I get:

"The folder you entered does not appear to be valid. Please choose another" I don't even know where to begin with this, as it's not saying much to help me troubleshoot. Any ideas?

2
  • 1
    Does this \\192.168.x.x format work?
    – jc__
    Dec 4 '17 at 14:28
  • no i get the same error. this is indeed the format suggested by windows on the getgo but..
    – Return-1
    Dec 5 '17 at 13:45
1

Windows 10 is deprecating SMB protocol version 1, not installing server components for it by default anymore, and automatically disabling the client components for it if it does not seem to be needed. Since SMBv1 has a critical design flaw that enabled the spread of the original WannaCry ransomware worm, this is a good thing.

You should verify that your Samba configuration does not have a server max protocol = setting (either as explicit configuration or as an implicit default setting) that will restrict Samba from using SMBv2 or SMBv3.

Run testparm -s --parameter-name "server max protocol" /etc/samba/smb.conf 2>/dev/null. If the response is anything that doesn't begin with either SMB2 or SMB3, your Samba configuration is currently restricted to SMBv1 only.

With up-to-date versions of Samba, fixing this typically requires only removing any explicit server max protocol restrictions from the configuration. If you have an old version of Samba that defaults to using SMBv1 only, you can probably add a server max protocol = SMB2 or server max protocol = SMB3 to explicitly enable the newer protocol versions. If your version of Samba does not support these configuration options, it is a really old version that should be updated as soon as practical.

1

Try accessing it this way via Windows Explorer or the search bar:

\\192.168.x.x

You'll see all of the folders that way.

You can also try this via the command line by specifying one of the folders after the server's IP address:

net use S: \\192.168.x.x\folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.