1

I have two laptops: a Windows 10 box and a SuSE Linux box (2011-02-21 build of 2.6.37). They're on a wireless LAN and both browsing the internet via the same hub. Yet TCP doesn't work between them. What could the reasons be?


I wrote a server process that waits for a connection. I wrote a simple client process that makes that connection. When I run them on the same box, they connect fine, whether they're both on Windows or both on Linux.

However when I try to connect the client on Windows to the server on SuSE, the SuSE box does not get a connection.

Indeed when I use the utility Test-NetConnection -ComputerName 10.226.12.12 -Port 8777, this Windows 10 standard test program also cannot connect. So that even takes my own client software out of the picture. And after trying TCP, Test-NetConnection then tries ping/ICMP and that also fails. The final report is:

WARNING: TCP connect to (10.226.12.12 : 8777) failed
WARNING: Ping to 10.226.11.30 failed with status: DestinationHostUnreachable

On the SuSE box, netstat -l shows the port 8777 is indeed being listened to. /usr/sbin/iptables -L -v|grep policy shows Chain INPUT (policy ACCEPT) There are no more specific rules under INPUT as I did iptables -F INPUT. (I've also subsequently tried iptables -I INPUT -p tcp --dport 8765 -j ACCEPT and no improvement.)

Back to my own software, I'm giving the numeric address 10.226.12.12 to gethostbyname() and that's working.

However for connect() I'm getting "Connection timed out."

If I set the client to connect to say yahoo.com:80, the connection succeeds. (My software has nothing to do with HTTP; I only use this as an example of a listening port my readers will be familiar with, and to show that my laptop is indeed connected to the WiFi and able to make connections.)

Meanwhile if I run the client (it's portably-written C) on Linux, it connects to the server, so I know the port number is correct.

Looking through the Linux box's Start Menu-->Control Center-->Network Connections I am not seeing any other setting such as "don't trust my LAN" or something.

My guess is that there might be some security layer blocking this, but WHAT security?

-- would Windows 10 somehow stop me from connecting out? I have Network Profile set to "private": "for a network that you trust such as at home or work"

-- would the hub? I have no idea about it: not only am I not knowledgeable about network hardware, I am an short-term contractor... at a company renting space from a "coworking site" company that in turns rents from a bigger company renting the loft premises and doing the networking. So it'd be difficult to even find anyone who knows anything about the network hardware.

-- Would SuSE? I don't see anything on its network configuration saying something like "don't trust computers on the LAN"

  • 1
    Your question is very vague about what software your using. Try the obvious things first: Does the client have a firewall blocking out going connections? Is the server blocking incoming connections? Have you verified that the service is listening on the correct port (netstat)? Try to connect from Win10 using telnet to the port and see if and what info is returned. – jc__ Dec 1 '17 at 14:46
  • If you are trying to connect via port 80, you will need a web service running on the Linux machine. – Raman Sailopal Dec 1 '17 at 15:14
  • No, the port happens to be 6868, chosen at random. My example of yahoo.com:80 was simply of a public port that readers would be familiar with. – Swiss Frank Dec 1 '17 at 15:40
  • The software is in-house. Does the client have a firewall blocking out going connections? I don't think so: Windows Defender Firewall is: On. Incoming connections are blocked, but the server's not on the Windows box. Notifications will be shown if anything is blocked (and I see no notificiations.) The WiFi LAN is shown as being covered by these policies. On the server side, netstat -s IS showing that the port is being listened to. On the client, I don't have telnet, but trying to connect with PuTTY to the IP address and port is getting a "connection timed out." – Swiss Frank Dec 1 '17 at 15:50
  • Note NO networking seems to work. For instance the SuSE box is exporting a directory via Samba which has worked fine in the last few weeks to a Windows 7 box (in a different environment) but it is likewise invisible to this Windows 10 box. Not only is it not showing up visibly in the network neighborhood, even typing \\10.226.11.34\Share is not finding it. – Swiss Frank Dec 1 '17 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.