0

I am running KDE neon with a Budgie desktop. I am using it to work on a weird site that launches a PHP site in a Docker image as well as a Scala site in another Docker image. The Scala sites talks to the PHP site to get some legacy data and pages. (I didn't write this; it’s a nightmare.) I am running it on a 250 GB Samsung EVO SSD in my computer and for some reason, every single thing I do takes up tons of disk space. For instance. I ran a query that returned 95 K results. That took up over 50 MB of disk space. It doesn't seem to be freeing any of it at all.

I cleared out a full GB on four separate occasions and lo and behold, it fills right back up and literally leaves me with flat 0 disk space. This happens in the course of about 5 minutes. I've been using this computer with this hard drive since May and have had no problems with it. I get that it's a little small, but it seems as though I should be able to free up space and have it stay freed unless I download or create something on it. But it seems like everything I do just annihilates it recently. I mean to the point where if I hit tab twice in terminal to use the shortcut to find a file, it fails. Says it can't write the temporary file. I can't even access MySQL since it doesn't have disk space to run. I get that it has to use some disk space to run queries, but if it used as much as it is right now, I would have been out of disk space months ago. I run a lot of queries with large(ish) result sets.

I mentioned Docker and Scala and all that earlier because I thought it would be useful info. I have checked the logs and nothing seems to be out of the ordinary. When I run

$ du -hs * | sort -rh | head -10

command to find the disk usage, it doesn't report disk space usage anywhere near to what I would expect a full SSD to look like. Here is the output:

23G     home
6.8G    usr
1.1G    var
749M    opt
701M    lib
126M    boot
90M     run
72M     tmp
17M     etc
15M     sbin

So I have no idea what’s going on. It seems kinda weird this just seemingly popped up out of nowhere on me, but if anyone can lend some advice, I promise to return it.

  • What's the output of lsblk -o NAME,SIZE,TYPE,MOUNTPOINT ... it's possible that you don't have enough space reserved in your root partition for /run ... systemd likes to gobble disk space for /run – RubberStamp Dec 1 '17 at 3:19
  • Check the file systems involved. Block sizes, inodes, number of files, metadata all may be causing this. – Zip Dec 3 '17 at 20:05
  • @RubberStamp Here is the output of the command - ` NAME SIZE TYPE MOUNTPOINT sdb 931.5G disk ├─sdb4 766.3G part ├─sdb2 100M part ├─sdb7 15.9G part ├─sdb5 450M part ├─sdb3 128M part ├─sdb1 300M part └─sdb6 148.4G part sdc 29.3G disk └─sdc1 29.3G part sda 232.9G disk ├─sda2 216.5G part / ├─sda3 15.9G part [SWAP] └─sda1 512M part /boot/efi ` I am running a 250GB SSD along side of a 1TB partitioned HDD. – jeffro25 Dec 4 '17 at 13:35
  • I had a typo... it should have been FSTYPE ... however, in this case... df -h is more informative for the question... sorry about that. It's much easier to read text output from commands if the text is added to the content of the question rather than in the comments. – RubberStamp Dec 4 '17 at 13:53
  • Yes, please add the output of df -h by editing your question. – Markus W Mahlberg Dec 10 '17 at 9:33
0

You could use a disk usage visualizer such as Baobab or FileLight to give you a graphical representation of your disk, thus allowing you to pinpoint the area(s) of concern quickly.

Btw, you can check the disk usage of Docker with docker system df, and remove unused data with docker system prune.

  • I ran the command and it was handy. Looks like I'll be able to reclaim some of that disk space. Roughly 1GB. Thanks for the advice! – jeffro25 Dec 4 '17 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.