1

I'm experiencing an issue with an HP ProBook 6470b that I'm hoping to solve.

The problem is that at boot time (either from cold boot or when performing a reboot), my external monitor isn't detected and I have to disconnect and connect it in order for it to start working which is annoying as I use it as my primary display.

Display is connected to DisplayPort on the computer using an adapter and the monitor itself uses an HDMI connection, running from an Intel HD 4000 card.

This behavior happens on Linux as well as Windows, but I'm hoping that there's a chance this might be able to be resolved or worked around under Linux. Kernel is currently 4.13.0-17-generic.

Currently after booting up with the monitor connected, xrandr doesn't see it and only detects the internal LVDS connection; is it possible to somehow trigger a reset of the DisplayPort connection as if I were to disconnect/reconnect it physically?

Running udevadm monitor shows the following output when plugging in the monitor:

KERNEL[10564.460492] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
UDEV  [10564.461519] change   /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)

Update: I've tested the DisplayPort-to-HDMI adapter & monitor with a system running the same installation of Linux with an AMD Radeon HD 6470M on an EliteBook 8460p and it works as expected at boot time, so I'm presuming this may be limited to the Intel HD Graphics 4000 card in the ProBook. I've tried switching between the "intel" and "modeset" drivers in Xorg's configuration with no change.

Update 2: xrandr shows the monitor is located on output HDMI-3, here's the output on boot, and then after reconnecting the external display:

HDMI-3 disconnected (normal left inverted right x axis y axis)

HDMI-3 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm

To clarify: when this occurs, the monitor displays "No Signal" briefly. I've tried passing HDMI-3 to the video flag at boot time through GRUB which has no effect, as well as trying to turn the display on by running xrandr --output HDMI-3 --auto to no avail.

Thanks for any insight that can be provided.

  • What happens when you type this in a terminal: xrandr --current? – 719016 Nov 30 '17 at 22:13
  • 1
    On clean boot, it only shows that LVDS-1 is connected and all other outputs are disconnected. – user255641 Dec 1 '17 at 7:33
1

After further testing, this issue appears to be caused by a hardware-level issue when using the Legacy BIOS boot mode, as the monitor is detected correctly over DisplayPort when using UEFI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy