3

I'm new to linux and I decided to install Debian 9, I installed it in my HDD in UEFI mode with a USB stick and the DVD 1 iso found here: https://cdimage.debian.org/debian-cd/current/amd64/bt-dvd/. I had some issues with network drivers but I managed to solve them. Then I wanted to install Nvidia propietary drivers, my laptop is a MSI GL62-7RDX which comes with an i7-7700HQ CPU and a GTX 1050 (2GB) graphics card, I followed the steps specified here: https://wiki.debian.org/NvidiaGraphicsDrivers#Debian_9_.22Stretch.22 which are:

  • Add non-free repositories by modifying the sources.list file.
  • Execute the following commands as root:

    apt update
    apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver
    
  • Reboot

The problem is that when I rebooted I only got a black screen with a blinking cursor. I decided to follow the steps shown here: https://wiki.debian.org/NvidiaGraphicsDrivers#Backing_out_in_case_of_failure in order to throw back the changes. After rebooting I could see the login screen, but when I tried to login I got a login loop, despite of the password being correct.

I also tried to install Nvidia drivers as shown here: How to install the latest NVIDIA drivers on Debian 9 Stretch Linux but I got black screen with blinking cursor again.

In summary, I would like to know how to properly install Nvidia drivers in my laptop. I think I am missing something and that the problem is related to my specific hardware, because a few days ago I tried to install Ubuntu 17.10 and it only worked if I added nomodeset by pressing e in the GRUB.

  • 1
    Sorry I can't help you with your problem but I just thought I'd say, “welcome to Unix & Linux”. It’s a pleasure to see someone’s first question being so well researched and such care taken to write their question so that it’s clear what the problem is. Hope you get a good answer. – Anthony Geoghegan Nov 30 '17 at 18:01
  • Thnak you very much @AnthonyGeoghegan – AxiomSword Nov 30 '17 at 18:16
0

I had exactly the same issue the first time I tried to install Nvidia driver.

If you're on a laptop you have Optimus (hybrid) graphics. You had to install "bumblebee-nvidia" to install the Nvidia driver. It was stated on the page you used to install the driver.

https://wiki.debian.org/NvidiaGraphicsDrivers#Identification

Note: if this lspci command returns more than one line of output, you have an Optimus (hybrid) graphics chipset, and the instructions on this page do not apply to you. Check the Bumblebee page instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.