1

I updated from wheezy to Jessie, everything went smoothly, until I restarted. When it booted back up, all I got was grub rescue (error: file '/boot/grub/i386-pc/normal.mod') not found. ls gives me (hd0) (hd0,msdos1). ls (hd0,msdos1) is a blank line. Nothing in it. I booted from a live CD and tried running boot repair, but that failed at "grub-pc purge cancelled". I mounted the drive. Everything seems to be there. I chrooted in, purged grub, and reinstalled grub. No change. I have the exact same issue. I completely purged grub, without reinstalling. Still no change. I am at a loss, I do not know how to fix this, or even how to continue troubleshooting. Any help would be appreciated. (I know this is highly specific but I have searched everywhere.)

As requested grub-install /dev/sda from chroot yields:

Installing for i386-pc platform.
Installation finished. No error reported.

update-grub yields:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-4-686-pae
Found initrd image: /boot/initrd.img-3.16.0-4-686-pae
Found linux image: /boot/vmlinuz-3.16.0-4-586
Found initrd image: /boot/initrd.img-3.16.0-4-586
Found linux image: /boot/vmlinuz-3.2.0-4-686-pae
Found initrd image: /boot/initrd.img-3.2.0-4-686-pae
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map.
done

/dev/sdb seems to be my live CD.

Edit:

I used the super grub livecd, and now I can boot into Debian. From the operating system, I removed my livecd, then tried running grub-install /dev/sda and update-grub. When I reboot, I end up at the same grub rescue screen.

  • Is your /boot is on a separated partition? – Ipor Sircer Nov 30 '17 at 0:08
  • Not as far as I can tell – Academiphile Nov 30 '17 at 0:09
  • Does /boot/grub/i386-pc/normal.mod exist? Is there only one hdd? – Ipor Sircer Nov 30 '17 at 0:11
  • From within the os yes, and yes. – Academiphile Nov 30 '17 at 0:13
  • please add the full output of grub-install /dev/sda to your queston. – Ipor Sircer Nov 30 '17 at 0:17
1

A simply and effective way to reinstall grub in your PC without complications is with the Boot-Repair-Disk utility (here is the download page: https://sourceforge.net/projects/boot-repair-cd/files/latest/download), this is a live system that have tools for reinstalling the grub bootloader.

Steps: just download, burn in a USB with unetbootin or etcher and boot in your PC, when the system start you will see a windows with two options, select the one that says "recommended repair", now connect to internet (it will download the grub packages that corresponds to your system, Debian in your case), let the program analyse your partitions and just follow the steps, you will solve the problem in less than 5 minutes. When you finish, reboot and make a "sudo grub-update" in a terminal on Debian, voila! Grub fully installed and configured again.

Another tool that can help you is Super Grub2 Rescue (here is the link: https://www.supergrubdisk.org/), weighs less than 20MB, this will help you to boot directly in Debian without installing grub.

0

Try running: echo "(hd0) /dev/sda" > /boot/grub/device.map

  • From grub, from the live CD, or from the live CD in chroot? – Academiphile Dec 1 '17 at 19:27
  • Ran it from within chroot, since that's the only thing that made sense. Still the same error. – Academiphile Dec 1 '17 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.