3

I wanted to load customized edid so I have added it's name as "drm_kms_helper.edid_firmware=edid/edid.bin" and I kept the edid under /lib/firmware/edid/.

But after booting the system, I cross checked from user space. It is not loading: cat /sys/module/drm_kms_helper/parameters/edid_firmware.

I've enabled the configurations DRM_LOAD_EDID_FIRMWARE=y.

Can anyone help me with this?

1 Answer 1

1

check what the kernel says at boot time with dmesg -H. In my case with a similar config:

[  +0.000001] Kernel command line: (removed irrelevant options) drm_kms_helper.edid_firmware=edid/2560x1440.bin 
[  +0.000180] [drm] drm_kms_firmware.edid_firmware is deprecated, please use drm.edid_firmware intead.

later...

[  +0.003042] [drm:drm_load_edid_firmware] *ERROR* Size of EDID firmware "edid/2560x1440.bin" is invalid (expected 0, got 127

Not sure what the cause is, but you should see some errors about your EDID file too.

EDIT: changed drm_kms_firmware.edid_firmware to drm.edid_firmware, still have the invalid size error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .