9

I have Debian 9 Stretch installed in my pc,and when I want to hear some music i can't hear it well.I discovered in audio settings that the A2DP profile was there but nothing happens when I select it.There's a way to force the A2DP connection when connected the headset to the pc.I already paired it btw.

Help is appreciated.Thanks.

17

I am using a SoundBuds Curve headset in Debian 9, and have had the same problem, I was unable to switch from the HSP/HFP profile to the A2DP profile.

What fixed the issue for me, was editing /etc/bluetooth/main.conf. First add the following lines under the [General] tag (copied from audio.conf, I found searching for a solution):

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

Next enable support for multiple profiles, which can be found a few lines below in main.conf:

# Enables Multi Profile Specification support. This allows to specify if
# system supports only Multiple Profiles Single Device (MPSD) configuration
# or both Multiple Profiles Single Device (MPSD) and Multiple Profiles Multiple
# Devices (MPMD) configurations.
# Possible values: "off", "single", "multiple"
MultiProfile = multiple
  • 4
    Last, restart Bluetooth service: sudo systemctl restart bluetooth – Antonio Vinicius Menezes Medei Apr 18 '18 at 2:41
  • 1
    Did the trick for me with my Sony WH-1000XM2 on Debian 9 – 56ka Dec 12 '18 at 5:41
  • (sorry I forgot to log in when I edited your post so the modification will be requested as anonymous user) – 56ka Dec 12 '18 at 5:41
  • After a long time of trying to fix this problem this was it. Thanks! Working flawlessly – Yehonatan Dec 18 '18 at 9:55
  • After several weeks of use I can say it works BUT the problem is still that I have to restart the bluetooth service everytime before to connect my headset... – 56ka Jan 4 at 10:14
0

I've also been having trouble with the soundbuds curve and my MBP running MacOS Mojave. It does connect fine, but has trouble switching back from "headset" mode/HSP|HFP to "music" mode/A2DP. I do run several virtualbox machines via vagrant for my development tasks. I only mention that because I previously used an app called oversight that basically sat between your camera & mic devices and OS so it would alert you if something tried to access them. I noticed starting debian VM's would trigger the Mic which may have played into my particular problem. I did run across this article, maybe there are some parallels for Debian?

Other configuration issues may also disable AptX audio. As Darko.Audio explains, on a Mac, if you’re using 2.4 GHz Wi-Fi, if you have more than two Bluetooth devices connected to a desktop, or if you have more than one connected to a laptop, macOS drops down to lower-quality SBC audio over the Bluetooth Advanced Audio Distribution Profile (A2DP) connection. That’s according to Apple.

...

Technically, when you’re just using the headphones as a sound output device, they’re using the A2DP Bluetooth profile, and ideally using AptX for maximum sound quality. When you need the microphone, they’ll use the headset profile or hands-free profile (HSP or HFP). This allows for both recording via the microphone and playback via the headphones, but the headphone sound quality is terrible when using HSP or HFP.

Ref: why bluetooth headsets are terrible on windows pcs

protected by Community Oct 3 at 14:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.