2

I just got a new Gigabyte Brix machine (https://www.gigabyte.com/Mini-PcBarebone/GB-BKi5A-7200-rev-10#ov). It has an Intel HD 620 graphics chip.

I've been trying to install Linux on it but no luck. I'm unable to get X working.

I've tried Ubuntu (16.04LTS, 17.04 and 17.10) as well as lubuntu (same versions) and I've also tried the latest Fedora desktop. All of them behave the same, blank screen (no signal, the monitor goes into powersaving mode) after booting into them. I get the grub menu but if I let it pass to boot up the graphical installer the screen goes blank. I've tried this on three different monitors, two 4k monitors and one QHD (2560x1440). None of these combinations work out of the box.

I managed to get past this and into the graphical installer by modifying the boot parameters, adding nomodeset, in the grub menu. This booted up the graphical user interface in 800x600 resolution. I managed to install the system that way but as soon as I booted into it I got the same problem, blank screen after the grub menu. I again got into it in low res with nomodeset and (on Ubuntu 17.04) installed the Intel Graphics Update Tool (https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.6). I updated the driver using this tool and rebooted but still no luck.

I'm running out of ideas here and I'm sad to say that I might end up installing Windows on this thing. I'd really like to avoid that so I'm hoping someone here can give me some idea of what more to try.

I've googled and found some similar questions but none of them seems to have a valid answer.

Update: here's a gist containing various log file and command outputs that may be relevant: https://gist.github.com/StFS/603a665a835967121a39da830ad55675

  • Could you provide your full dmesg output? Boot up normally with the black screen. See if you can turn it off with the power button. If not reset and then boot up with nomodeset. Then copy the contents of /var/log/dmesg.0 (first rotation of dmesg which is your last previous boot.). – jdwolf Nov 28 '17 at 0:44
  • I booted up the computer but I don't have a dmesg.0 log file. So instead I booted it with nomodeset, installed openssh-server on it and then re-booted (with no nomodeset flag). Then I log into it via SSH and ran the dmesg command. It doesn't look like I can attach files here so here is a link to a gist that contains various log file content and command outputs (including the output of dmesg): gist.github.com/StFS/603a665a835967121a39da830ad55675 – StFS Nov 28 '17 at 9:29
  • Your problem appears to be related to this: wiki.archlinux.org/index.php/… I would suggest testing the kernel parameter first: video=SVIDEO-1:d since its for a different distribution and you can rule things out quicker that way. In any case this should be considered a bug as this a workaround. – jdwolf Nov 28 '17 at 11:53
  • Since loading the driver in early boot seems to fix it the issue might have to do with the autodetection within the driver itself because the screen is currently in use by the console so it starts the output on the next available output. If there is an official way in ubuntu load intel gpu drivers in early boot you might wanna do that instead. This does all heavily suggest its a bug with the driver. – jdwolf Nov 28 '17 at 11:56
  • Tried adding the video= parameters but no luck :-( – StFS Nov 28 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.