1

I have tried switching my server to a different kernel from what my hosting provider supplies. It should just be a case of updating the kernel from the hosting providers management pages, reboot and the default CentOS kernel is used. This has worked on 1 server but not on the other.

On the broken server it just boots to a grub2 menu. I've managed to get it boot again by running the following:

set gfxpayload=text
insmod gzio
insmod ext2
linux16 /boot/vmlinuz-3.10.0-693.5.2.el7.x86_64 root=/dev/sda ro crashker
nel=auto rhgb console=ttyS0,19200n8 net.ifnames=0
initrd16 /boot/initramfs-3.10.0-693.5.2.el7.x86_64.img
boot

I took these by looking at the /boot/grub2/grub.conf on the server that did work without issue.

After doing the following the server succesfully boots up, but the changes aren't persistent, if I reboot I'm back to the grub2 menu and I need to do it again.

I've looked around and saw some places say to run update-grub but I don't have that command.

I also found to try the following:

grub2-mkconfig -o "$(readlink /etc/grub2.conf)"

This just seems to print the script out and doesn't do anything. If I reboot again I'm back to the grub2 menu.

Anyone got any ideas on how to resolve this.

I'm running CentOS 7 and the kernel is now on 3.10.0-693.5.2.el7.x86_64

Thanks for any help you can provide.

1 Answer 1

1

I found out I should have run grub2-mkconfig -o /boot/grub/grub.cfg to save the changes instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .