1

I'm using Debian Stretch LXDE (OpenBox) in a dual monitor setup. I activated the openbox context menu of my second screen by setting

Desktop (right click) -> Desktop Preferences -> Advanced (Tab) -> Show menus provided by window managers when desktop is clicked (Checkbox)

My 1st screen context menu appears as it defaults.

So how do I activate the OpenBox context menu on the 2nd screen?

I already tried to figure out some settings in /etc/xdg/openbox/... but with no clear results.

Edit

To clarify my problem: Every screen has its own settings, available by Desktop (right click) -> Desktop Preferences per default. As soon as I activated the window manager context menu the Desktop Preferences disappears and I can't undo my settings.

Edit (2017-12-05)

Left screen desktop context menu Left screen desktop context menu

Right screen desktop context menu Right screen desktop context menu

The setting caused the right screen desktop context menu, originally made on the right screen desktop The setting caused the right screen desktop context menu](![Left screen desktop context menu

  • What do you mean with context menu? The root-menu of Openbox (menu.xml)? Or the window-list menu of Openbox? Also it might be helpful to see your rc.xml. – Raphael Ahrens Dec 5 '17 at 10:32
  • I added some screenshots. Every screen provides its own dekstop context menu. And I like to deactivate the openbox context menu on the right one, I activated by checking the option shown on the 3rd screenshot. – codekandis Dec 5 '17 at 13:54
0

So you need to re-enable the PCmanFM Desktop, this is the software which gives you the Windows like menu with create new, etc.

I haven't found the exact option which allows you to do this, but from the PCmanFM wiki, the man page, and the Arch wiki I gathered, that there should be an option in the ~/.config/pcmanfm/default/desktop-items-$XYZ.conf where $XYZ is a number for your screen starting from zero.

There you should find an option to switch the menu from PCmanFM back on. But I don't know which the name of the option and the possible values. But by comparing the two files you will have you should see a relevant difference.

So running

diff ~/.config/pcmanfm/default/desktop-items-*.conf

Should give you a good clue.

In addition there is ~/.config/pcmanfm/default/pcmanfm.conf for genereal options.

  • Feel yourself gifted with beer as much as you can drink! To be specific the solution is to set show_wm_menu=0 in the desktop-items-*.conf file in question. – codekandis Dec 5 '17 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.