0

Apparently tensorflow needs cudnn6 to use the gpu. I have cuda 8 and cudnn5 and 7 but not 6. I get this error whenever I try to import tensorflow after installing tensorflow-gpu: ImportError: libcudnn.so.6: cannot open shared object file: No such file or directory

I have cuda-8.0.61-2 installed from the repositories.

So I got cudnn6 from here: https://aur.archlinux.org/packages/cudnn6/

And tried make -si but I get: error: target not found: cuda-8.0

Anyone having the same problem? How could I fix this?

  • 1
    That's a broken PKGBUILD, the depend should be something like cuda >=8.0 If you read the comments, there is an allegedly working PKGBUILD pasted there. – jasonwryan Nov 27 '17 at 16:54
  • @jasonwryan: Why don’t you post that as an answer? – G-Man Nov 28 '17 at 5:40
  • @G-Man because it is one of those problems "that can't be reproduced..." There is no value in having it legitimised with an answer. – jasonwryan Nov 28 '17 at 5:47
  • @jasonwryan Oh didn't see that comment. Thank you! – Atirag Dec 1 '17 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.