4

I want to get a WiFi dongle with the 802.11AC or later standard that is compatible with Linux 4.13 (with Ubuntu 17.10) for a desktop PC (Streacom FC8 mini unit), 64 bit, intel core i3-2130).

Context: I have an Ethernet connection but a flatmate pulled it out in the past because he suspected that it was slowing down the connection for everyone else (which may be true). I went and bought a Vivid Wireless router and used that for a couple of months, but it costs $90 per month for an unlimited plan. A few days ago I reconnected the Ethernet to the old router and have used it fine, however an hour or so ago I couldn't use the internet and it would prompt me to log in to the router ISP gateway. So I suspect that the flatmate denied access for the Ethernet connection as he has access to the gateway, although he denies changing anything. While resetting the router may cause the username and password of the gateway to change to the default, there is no button to be felt after prodding around in the reset pinhole, so I'm unable to reset it and can't login in to the gateway. I've posted on a Telstra Forum saying the same thing.

Initially the dongle I had worked with Windows but it wouldn't and was not supported for Linux. So I bought another dongle that was Linux compatible but it didn't work, so I got a refund. Here are the results of trying to get it to work. I read this which says that AC dongles may be difficult to setup.

I also read other posts e.g. here, here and here that are pretty old so I'm hoping that there are updates in more compatible AC dongles.

A useful source of information is https://wikidevi.com/wiki/Main_Page.

There's also http://www.wirelesshack.org/top-linux-compatible-usb-wireless-adapters.html.

The TP-LINK Archer T4U is a dual band 802.11ac USB adapter.

It uses the Realtek RTL8812AU chipset which many have had good results getting 802.11ac in the 5GHz range working with Linux. Good 802.11ac USB dongles have been slow to come about and often require some setup for the drivers.

Here is a link to Realtek RTL8812AU chipset and Linux. https://github.com/abperiasamy/rtl8812AU_8821AU_linux

If you are looking for a easy setup than going with a known working wireless-N dongle would be better.

Then from the https://github.com/abperiasamy/rtl8812AU_8821AU_linux readme:

Known Supported Devices:

  • COMFAST 1200Mbps USB Wireless Adapter(Model: CF-912AC)

Interestingly, the seller of the first dongle said that the chipset is RTL8812AU! So I'll try that with the instructions in the abperiasamy repo.

That didn't work.

I bought an AC600 WiFi dongle, which works plug and play, which is able to connect to my router sometimes, and only sometimes.

I went back to using Ethernet connected to the router, but the housemate wanted to unplug it on Feb 1 2018, so I did.

So I used a WiFi extender (Netgear WN3000RP) that is already in the house (but is meant to be used for others; although nobody has complained. I plugged an Ethernet cable into that and connected the other end to my computer.) The internet works fine with this setup. I bought another extender, getting an AC1200 one, in order to get more reliable and faster speeds, although the speed with using up to 300 Mbps works pretty well.

  • 1
    If this is for a laptop why not replace the wifi card (if possible)? – Ignacio Vazquez-Abrams Nov 25 '17 at 5:07
  • 1
    It's a desktop. Replacing the WiFi card may be an option but is probably more expensive and may take longer than a plug and play USB dongle, if it's available. – James Ray Nov 25 '17 at 5:15
  • I don't know if there is enough room for that. I have only one empty PCI expansion slot on the back that is ~7 cm tall. – James Ray Nov 25 '17 at 5:23
  • I know it doesn't come with a half-height bracket so you'd probably have to remove the bracket and find a way to mount the antenna connectors on your case. But it's a PCI Express card so the whole thing might be moot. – Ignacio Vazquez-Abrams Nov 25 '17 at 5:25
0

Based on the details on my question and comments, no AC dongles seem to work. This dongle works sometimes, but only sometimes, so effectively it doesn't. As an alternative, use Ethernet to connect to a WiFi extender, or directly to the router.

  • If anyone finds a better solution, I'd love to hear it, as relying on Ethernet can be inconvenient e.g. when not at home or when moving, even though it is faster. – James Ray Mar 13 at 3:02
  • Actually, my desktop didn't work last time I tried it, while my laptop does, and I have also gotten a new desktop. – James Ray Mar 13 at 3:07
  • I haven't personally tried this yet, but a reddit comment indicates that kernel 4.19 has support for MediaTek MT76 based USB 802.11ac dongles: reddit.com/r/linux/comments/9dbd7y/… Some adapters using that chipset are Edimax EW-7822UAC, Netgear A6210 and TP-LINK Archer T1U. I have no idea how well they actually work. – Michael Burr May 18 at 17:45
  • Looks like there's a mistake in the list of adapters above: the Edimax EW-7822UAC appears to use the RTL8812AU chipset, not a MT76 chipset. – Michael Burr May 18 at 19:00
  • Yeah I have been keeping up to date with using the latest LTS kernel. WiFi doesn't work on the desktop, but I'm happy to stick with Ethernet on the desktop. WiFi does work on my laptop. – James Ray May 20 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.