3
Linux anarki 3.2.0-2-amd64 #1 SMP Fri Jun 1 17:49:08 UTC 2012 x86_64 GNU/Linux

Distributor ID: LinuxMint
Description:    Linux Mint Debian Edition
Release:        1
Codename:       debian

When my laptop boots I need to enter a harddrive password. I also have to manually skip the memory test during POST with the escape key so I know my keyboard works.

After booting into Linux I get to GDM3 or LightDM (tried both) login screen but my keyboard and mouse won't work. This includes a mouse and keyboard that have been connected via USB. When I unplug the USB keyboard and mouse and plug them in again, they work, but not the internal keyboard and trackpad, because I can't unplug/plug those. The numlock and capslock keys don't even light up when I press them. CTRL-ALT-F1 does not work.

I have found problem descriptions on the internet from 2011, with solutions like renaming /var/run/udev or /run/udev. There also was a proposed solution of removing the keyboard and mouse settings from xorg.conf because that is handled by evdev now, but all of these solutions didn't work.

The problem does not occur when I start in recovery mode. The keyboard works fine in the terminal, but as soon as I start X by doing startx or starting gdm3 or lightdm the keyboard and mouse cease to work. In the scenario of going through the recovery boot option the screen also stays blank when I start X.

I will be browsing through stackexchange looking for other possible solutions to try out.

6
  • Do you get any error messages in the console when starting up? Also what app is it that is asking for the password? Is it a drive encryption app or a drive locking function on the motherboard such as on the Dell laptops? Jun 14, 2012 at 20:49
  • Just faced the same problem after upgrade (debian 7) Are there any ideas how to fix it? Oct 1, 2015 at 23:02
  • @AntonProkofiev I never found the solution.
    – InFerNo
    Oct 19, 2015 at 7:54
  • @AntonProkofiev Are you using Synergy to share mouse and keyboard? Try disabling it and see if the problem persists.
    – InFerNo
    Oct 19, 2015 at 8:00
  • @InFerNo Too late. I have reinstalled everything. Now i am on Debian 8. All things are working OK. Oct 20, 2015 at 16:54

1 Answer 1

2

I'm having the same problem. I've tried everything in the Mint LMDE thread. The only thing that works is unplugging and replugging in the mouse and keyboard. However no way to do this on the internal laptop ones so it's pretty much dead as a laptop.

4
  • 1
    I just went ahead and reinstalled everything. Really sad actually, can't be that we are the only ones..
    – InFerNo
    Jun 18, 2012 at 19:37
  • 2
    You're not, same thing happens to me on Ubuntu, are either of you guys using Synergy by any chance? Nov 16, 2013 at 18:08
  • Yes, I'm a Synergy user.
    – InFerNo
    Dec 18, 2013 at 23:09
  • What's Synergy? Jan 15, 2021 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.