1

After an update, my laptop keyboard doesn't work anymore when I want to login (while the touchpad does). This is true whatever the display manager used (xdm, lightdm). I can't even switch to console with ctrl+alt+F1. Note the keyboard works when I boot in recovery mode so the problem is related to xorg-*

I tried to reinstall xserver-xorg-input-kbd|evdev without result.

I am running under Debian sid. During the update the following packages related to the keyboard have changed: keyboard-configuration, console-setup, keyutils

Several questions seem related but none solved this issue:

Problem with keyboard and mouse in gdm3 and lightdm

Keyboard Problem with Debian testing and gdm3

Keyboard and mouse do not function in Debian


I fully reinstalled xorg which did not solve the problem ... The best I could do until now is to use a virtual keyboard ...

closed as off-topic by Jeff Schaller, Stephen Rauch, GAD3R, G-Man, Archemar Nov 25 '17 at 7:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, GAD3R, G-Man, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    The Debian Wiki does say "Should I use sid on my desktop? If you think you can handle a broken Debian system, sure. Do you know what to do if libpam0g breaks, preventing all logins? Do you know what to do if grub breaks, causing the boot process to hang forever? These things have happened. They will happen again. If you'd like to avoid the brown-paper-bag bugs like these, then use testing instead." – user8779 Nov 24 '17 at 11:11
0

Ok I did not find the reason for the problem but I found a solution : update the kernel

Not the answer you're looking for? Browse other questions tagged or ask your own question.