0

I was trying to install php7 and phpmyadmin in centos 6.9.

I have added epel-release and remi-release repository for centos 6

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm wget http://rpms.remirepo.net/enterprise/remi-release-6.rpm rpm -Uvh remi-release-6.rpm epel-release-latest-6.noarch.rpm

But when I run yum repolist all these repositories aren't listed in the list. Here is the list

Then I enabled repi-php70 repo to install php7

yum-config-manager --enable remi-php70

I have already installed PHP 5.3.3 in my system so i ran yum update php but yum reports:

No Packages marked for Update

Also ran yum --enablerepo=remi,remi-php70 install php php7 php70 but yum reports:

Package php-5.3.3-49.el6.x86_64 already installed and latest version No package php7 available. No package php70 available.

In case of phpmyadmin it should be found in epel-release repository. I have already added this repository so I ran yum install phpmyadmin but yum reports No package phpmyadmin available.

What am I missing here? How can I install PHP 7.0 and phpmyadmin? Any help will be appreciated. Thanks!

  • Does yum search epel-release not show the repository? – Raman Sailopal Nov 23 '17 at 9:13
  • Actually it shows the repository. It reports: "epel-release.noarch : Extra Packages for Enterprise Linux repository configuration" – Ashfaqur Rahman Nov 23 '17 at 9:17
  • Install that and then try to install phpmyadmin – Raman Sailopal Nov 23 '17 at 9:18
  • I have installed that already! $ yum install epel-release Package epel-release-6-8.noarch already installed and latest version This is the reason I am here! – Ashfaqur Rahman Nov 23 '17 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.