0

I am on CentOS 7. I have D-link DWA-131 Wireless-N USB Nano Hardware revision E1 adapter. I have downloaded and compiled it's drivers from ftp://files.dlink.com.au/products/DWA-131/REV_E/Drivers/DWA-131_Linux_driver_v4.3.1.1.zip. After installing and inserting the module 8192eu.ko my device is detected as USB Ethernet. How can i get it recognized as a wireless device, so that I can connect to a wireless network abc having password 12345678.

result of uname -a is

Linux linux-centos 3.10.0-693.5.2.el7.x86_64 #1 SMP Fri Oct 20 20:32:50 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

result of ifconfig -a is

enp0s20u3: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 54:2a:a2:47:dd:f6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
       inet 127.0.0.1  netmask 255.0.0.0
       inet6 ::1  prefixlen 128  scopeid 0x10<host>
       loop  txqueuelen 1  (Local Loopback)
       RX packets 7729  bytes 664831 (649.2 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 7729  bytes 664831 (649.2 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p4p2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
       ether f8:ca:b8:06:55:c0  txqueuelen 1000  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:1c:39:9e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0-nic: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 52:54:00:1c:39:9e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp6s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.22  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::374e:5cb2:ec50:9c4d  prefixlen 64  scopeid 0x20<link>
        ether 78:0c:b8:36:8e:31  txqueuelen 1000  (Ethernet)
        RX packets 122333  bytes 155288565 (148.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 84226  bytes 10510089 (10.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0  

enp0s20u3 is my USB device. It only shows up when I load 8192eu.ko using modprobe or insmod.

Device detected as USB Ethernet instead of Wireless

Device shown as wifi is 'internal wifi', but, the USB device is detected as USB Ethernet.

  • realtek based chipset products are junk unix.stackexchange.com/questions/252210/… – Rui F Ribeiro Nov 23 '17 at 10:02
  • @RuiFRibeiro I have another realtek based usb wifi device, and I am able to run it on linux (ubuntu and centos7)... for ubuntu I had to compile drivers, but it is working fine... its rtl8192cu based, the as in link you posted... it's drivers can be downloaded from (github.com/pvaret/rtl8192cu-fixes)... I am not able to install 8192eu on centos 7, as compiled drivers give the above mentioned problem – Manjeet Nov 26 '17 at 21:38
  • Nobody said they do not work at all. Just that they suck as a product. – Rui F Ribeiro Nov 26 '17 at 22:37
  • @RuiFRibeiro Can you suggest any other vendor or product which can work as usb wifi antenna, which is considered good for linux. – Manjeet Nov 27 '17 at 11:42
  • read my answer in the link of my 1st comment; it is not clear cut I am afraid.... – Rui F Ribeiro Nov 27 '17 at 12:27
0

For me it works only immediately after reloading the module:

modprobe -r rtl8xxxu; sleep 2; modprobe rtl8xxxu

(connection in NetworkManager pre-configured)

Besides I have additional options for it:

cat /etc/modprobe.d/rtl8xxxu.conf
options rtl8xxxu ht40_2g=1 dma_aggregation=1 rtw_power_mgnt=0 rtw_enusbss=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.