0

I have just upgraded my desktop system to RHEL 7, which comes with Gnome 3 as a window manager by default.

Irritatingly, whenever I drag a window to the top of the desktop, it automatically gets maximized as well, so I have to click the maximise button or drag it back down to get it to keep its size. I have looked both in Settings and in TweakUI, and I can't find any setting that seems to have with this to do.

How can I make Gnome stop maximizing my windows, preferably without having to change to another window manager?

2

The settings that control this are not available in the configuration dialogues. It has to be changed from the command line with gsettings, like so:

 $ gsettings set org.gnome.shell.extensions.classic-overrides edge-tiling false

After running this, the windows keep their size even when I move them to the top of the desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.