2

I am using Linux Mint 17, and I installed Viber to use as an alternative to Skype. I got the Viber client that is available on their website: https://www.viber.com/products/linux/
Whenever I start a Viber call, my microphone volume automatically gets turned to the maximum, and the person I'm calling tells me that my voice sounds robotic. I can manually lower the microphone volume, but I have to do this every time I start a new call.
This never happened in Skype, so it must be a setting in Viber, but I'm unable to change it in Viber.
I'm thinking there must be some way to prevent applications like Viber from doing this, but I don't know how.
Any help?

1 Answer 1

1

Question is a bit old but I had the same problem and finally figured out the solution. I'm also on Linux Mint, version 19 though.

In the home folder, Viber creates a settings database, ~/.ViberPC/config.db - it's just an SQLite3 database. I used SQLiteStudio to edit it.

There's a table called DefaultSettings, which by default is blank. I added a row. The ID is constrained to a foreign key which is basically the phone number you signed up to Viber with (you can get it from the Accounts table). The CodecID will probably be 0, you can get it from the VideoCodecPreferences table. The UnmuteSpeakers and AutoAcceptVideo are 1 or 0, as you prefer. InputVolumeLevel is the one that bothers you with your microphone - you will have to experiment to find a comfortable level here, I started off with about 50 and worked from there. OutputVolumeLevel is similar.

Save the database, restart Viber, and you should be good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .