0

After I unplugged my microphone, KDE switched my Built-in Audio Sound card to a GK106 HDMI Audio Controller that does not work (no HDMI). If I run System Settings > Multimedia > Audio and Video > Audio Hardware setup I can change the GK106 to the Built-in Audio (and APPLY), and sound works fine. But if I log out and log in again, Sound again does not work, and the setting shows again GK106 HDMI Audio Controller. In fact, after closing the settings and open it again, I see GK106 HDMI Audio Controller...

Any clues how to fix this?

Fully updated Fedora 26 with KDE spin running here.

  • Did you try changing the priority of the various devices in System Settings > Multimedia > Audio and Video > Device Preference? – bu5hman Nov 22 '17 at 4:41
  • @bu5hman: That's also weird. I see 4 devices, 3 of them grayed out (in particular, the two in the "Audio Hardware setup" tab), except "Dummy Output". BTW, my problems began when I unplugged a microphone. I use Linux since Redhat 2, and it never ever had a solid audio management, always full of bugs.... :/ – Luis A. Florit Nov 22 '17 at 22:45
  • I've often had issues with audio too. A few things to investigate: pavucontrol, alsamixer, and pulseaudio -k. – Sparhawk Jan 20 '18 at 1:40
  • Adding the line pactl set-card-profile 1 output:analog-stereo into the .xinitrc file restored the audio. It was definitely fixed only when I plugged back the microphone (???). – Luis A. Florit Jan 21 '18 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.