1

I have an Acer laptop with Windows 10 dual booted with Fedora. In the BIOS there were two options where I could set either "Windows Boot Manager" or "Fedora" to boot.

After servicing my laptop to get the internal fan replaced, I'm now unable to boot into Fedora. The option which was there in BIOS for Fedora has disappeared and only Windows remains.

The partitions for Fedora are all intact when checked in disk management.

Could anyone please help me restore Fedora in BIOS?

0

Check whether you're using legacy BIOS or UFI?

In UFI mode modern PCs have option to browse and select bootloader UFI file. If so please press f2 just after power on and from bios screen browse grubx64.efi in \boot section of Fedora. Set this bootloader at higher priority than Windows. Your machine shall boot Fedora after a reboot.

If you're using legacy BIOS, boot up the system with live fedora cd.. chroot into the fedora \ partition and reinstall grub. Google for the grub reinstallation procedure. This process shall work with UFI also.

Update grub menu entry correctly and you can chainload Windows also from grub bootloader

  • I'm using UEFI mode, but I don't have the option to browse and select the file. The problem is, where "Fedora" used to be there, it now shows "HDD: ". I set this as higher priority than windows bootloader but still went back to windows without going to grub2 – Karthik C Nov 22 '17 at 7:17
  • It's looking like somehow the Fedora bootloader has been corrupted. Please boot using live cd, chroot into your fedora installation, and reinstall grub – Abhik Bose Nov 22 '17 at 7:52
  • Will try the above method and get back to you. – Karthik C Nov 23 '17 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.