0

Clearly, dpkg --install does take a value, the package to install. And running just that dpkg --install without a value produces the expected error

dpkg: error: --install needs at least one package archive file argument

But given that the error message is literally nonsense, then what is causing the problem? The end result is that the build procedure fails, the package built is not installed, and the build log leaves just this as a clue to the error.

Things I've checked:

  • Passing a file which doesn't exist gives the correct error message "No such file or directory"
  • Running as non-root gives "requested operation requires superuser privilege"
  • Using --install=package.deb doesn't fix the problem (the --help is ambiguous whether you need an = sign for values, and it appears this is correct. Some arguments do, others don't).
  • 2
    You don't actually give any information about the failed build. Can you at least include the command you used and the error messages? – Faheem Mitha Nov 21 '17 at 17:06
2

The documentation does specify when = should be used. For example:

-i, --install package-file...

(no =) v.

--abort-after=number

The error message you’re seeing is displayed when you try dpkg --install= (with or without a value).

You need to run dpkg -i package or dpkg --install package, with a space, not =.

| improve this answer | |
  • Actually, that's specifically why I added the last bullet. I did follow the the instructions and did not add an =. Since that caused the problem described, I first tried a few alternatives before opening a question, and one of the things I tried was to see if adding an = helped. (no). – MSalters Nov 21 '17 at 16:47
  • OK, I wondered about that. AFAICT though the only way to get the error message you’re seeing is to run dpkg --install= (even without a value)... – Stephen Kitt Nov 21 '17 at 16:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.