1

I am running Linux Mint 18.2 64-bit from an external HDD with Gnome 3 as the desktop. I have several *.desktop files in my Desktop folder. But, they are not showing up. I have tried installing gnome-tweak-tools and toggling Icons on Desktop but it does nothing.

How can I get my desktop to be active? Thanks!

EDIT : I really don't think the issue is my *.desktop files because they are just the ones that come with the apps. But, in case there is something weird with gnome, here it is one of them:

#!/usr/bin/env xdg-open
[Desktop Entry]
X-AppInstall-Package=pidgin
X-AppInstall-Popcon=3151
X-AppInstall-Keywords= pigeon;gaim;chat;windows;live;aim
X-AppInstall-Section=main
Name=Pidgin Internet Messenger
GenericName=Internet Messenger
Comment=Chat over IM.  Supports AIM, Google Talk, Jabber/XMPP, MSN, Yahoo and more
Exec=pidgin
Icon=pidgin
StartupNotify=true
Terminal=false
Type=Application
Categories=Network;InstantMessaging;
X-MessagingMenu-UsesChatSection=true
X-MessagingMenu-UsesChatSection=true



X-Ubuntu-Gettext-Domain=app-install-data`

1 Answer 1

0

Could you please post the contents of one/some of your *.desktop files? It could be that they are not properly formatted.

(I would have just commented, but apparently I don't have enough points to do so)

Edit: I apologize. I didn't read your question carefully & didn't realize that the real issue was that the desktop was not active & the icons were not showing up (even with the fact that the title is very clear).

I do not use Gnome 3, but there is some info around the web on its desktop configuration. This post, by Joe Steiger, says to launch dconf-editor & navigate to "org > gnome > desktop > background" & check the box labeled "show-desktop-icons".

enter image description here

I should have remembered about dconf-editor. I don't think I've used it since I started using Linux Mint with Cinnamon desktop. Anyway, I hope this solves your problem.

6
  • I added it to the question. Too long to put in a comment.
    – Batcastle
    Dec 7, 2017 at 13:24
  • Okay, it looks alright to me. Are your .desktop files marked as executable? I believe some desktop environments only properly recognize them if the executable bit is set: $ sudo chmod +x my_desktop_file.desktop. Or change executable properties from your desktop environment's right-click -> Properties option, if available. Dec 8, 2017 at 1:08
  • Yes. They are marked as executable. I checked both the files and the menu which you mention before posting this. It's behaving as if there is a recommended package missing. In other words, it's working just fine otherwise, just this functionality isn't available for some reason.
    – Batcastle
    Dec 9, 2017 at 17:29
  • I updated my answer. Sorry about my misunderstanding. Dec 11, 2017 at 5:32
  • You don't need sudo if the files belong to you. Only use sudo if you really need to do so.
    – roaima
    Dec 11, 2017 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.