2

I am having an issue with the Mac OS Sierra. I have added a NFS config in a auto_nfs for 2 NFS shares and the autofs picks only the first one.

Here's my auto_master:

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-              auto_nfs    -nosuid
/-          -static

Here's my auto_nfs:

/build/mount1       -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,ro,tcp,nfc nfs://<some hostname>:/mount1 
/build/mount2       -fstype=nfs,noowners,nolockd,noresvport,hard,bg,intr,ro,tcp,nfc nfs://<some hostname>:/mount2

When I restart the autofs service with this sudo automount -cv I get the following message:

automount: /net updated
automount: /home updated
automount: /build/mount1 updated
automount: no unmounts

and the mount2 is not mounted under my build directory. If I change the order in auto_nfs to be mount2 followed by mount1, then I get only mount2 mounted.

If I put the

/-              auto_nfs    -nosuid

line at the end of the auto_mount then nothing works.

0

After traying everything I was able to resolve my issue. I gave my auto_nfs config to a colleague of mine. In order to make the thing simpler I send the config over Skype. When he applied it everything worked fine for him. Having this in mind I re-created my auto_nfs file using the content that I just send over Skype, then I called

sudo automount -cv

again and everything worked. It seems that there was some kind of issue with the encoding and/or spaces in the original file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.