1

Using Fedora 17, when I click an extension to install from gnome shell extensions site, it won't install!

How to know what the problem is?

4

What browser are you using? Does it give you an error or warning?

I'll take a wild stab in the dark: If you're using Chrome/Chromium, navigate to about:plugins and make sure "Gnome Shell Integration" is enabled. Then navigate back to extensions.gnome.org and when the ribbon appears at the top make sure you "Always Allow for this Site"

On Firefox you'll have to do something similar if you've turned extensions off. Browse to about:plugins and make sure libgnome-shell-browser-plugin.so is present / enabled. If it's not, upgrade Gnome Shell, or find it on your filesystem and link to it from to ~/.mozilla/plugins (you shouldn't have to do this though).

EDIT: If things are really broken, you could try reinstalling via: yum reinstall gnome-shell-3.4.1-5

1
  • thnx tht worked! I was using firefox, it shows gnome-shell browser integration in about:plugins but I didnt know if it is enabled or not but I tried with chorme now and it worked after tht I linked the so file in mozilla/plugins and now it works in firefox too
    – pahnin
    Jun 13 '12 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.