3

When I install kali linux found grub can't install. Then I'm using live USB tried to reinstall grub:

grub-install /dev/sda

I get this error:

grub-install: command not found

I am following this answer until

5) mount -o devpts pts /mnt/linux/dev/pts

It gets this error:

mount: special device pts does not exist

What should I do?

closed as off-topic by Rui F Ribeiro, schily, Jesse_b, Jeff Schaller, slm Aug 6 '18 at 3:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Rui F Ribeiro, schily, Jesse_b, Jeff Schaller, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • @peterh,you can't understand,because the answer unix.stackexchange.com/questions/183053/… has been modified.Can you understand me now? My problem had been solved.Thanks. – user261526 Nov 21 '17 at 9:33
  • @MichaelSmith Now I can understand, I decoded and fixed it :-) Good luck for the answer, happy linuxing in the future! (Btw, if an answer solves your problem, you can accept it by clicking the pipe icon to the left. It is a reward for the answerer and also shows, exactly which answer solved your problem.) – peterh Nov 21 '17 at 9:38
  • @I know,I want,but I'm new here,my reputation less than 15,so I can't vote to the good answer.I will compensate when my reputation more than 15. – user261526 Nov 21 '17 at 9:46
  • @IporSircer what? Kali is not off topic here! Please don't misinform users. – terdon Nov 21 '17 at 11:07
  • @MichaelSmith sorry about that. Kali is absolutely on topic here. The only issue is that many people seem to think that Kali is a toy instead of a professional tool aimed at experts. So we get a lot of question from newbies installing Kali, something they really have no business to do. – terdon Nov 21 '17 at 11:09
2

That seems to be a typo in the answer. The command should look something like:

mount -t devpts pts /mnt/linux/dev/pts

devpts is a type, not an option.