1

I added one user with myname(prashant) but i had not set any password for same user account. Still when i reboot(runlevel5), i os asked mi for password for same user account. I tried to login with without password as i not set, still authentication failure msg display. how it is possible?

OS : Cent os 6.4 I added more two users also but not beneficial. Please can any one tell me the reason and way to login with same user.

  • It sounds like you want to set an empty password for your user. Is that right? – dhag Nov 20 '17 at 20:57
1

From the useradd(8) man page:

   -p, --password PASSWORD
       [...] The default is to disable the password.

The way to allow login is to assign a password using passwd.

  • To allow login by using passwd it is ok, but when i need to use this command. I mean after just useradd or when. Because i added user already and restarted system. I am now using this command but it is setting password. Kindly let me know how i disable the password of created account and while creation of new account using useradd command how i disable the password. Thanks in advance. – Prashant Nov 20 '17 at 20:12
  • @Prashant Your question is unclear. Do you want to set passwd or not? – Arpit Agarwal Nov 20 '17 at 20:59
  • The question is clear: the OP wants to login and cannot because the system is asking for a password, even though none was set. – G-Man Nov 20 '17 at 21:07
  • Yes G-Man is correct, i just added user with useradd command and when i reboot machine it shows me to enter password for same user. – Prashant Nov 21 '17 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.