1

Heavily related to a question on the sister site (https://serverfault.com/questions/874943/debian-9-black-screen-during-install), I have recently picked up an HP ProLiant DL380 G5 and attempted to install Debian 9 on it (currently to a USB drive as I wait for my order of HDD's).

The OS setup would halt due to a NMI Watchdog error (to the swapper task just like above linked) if I did not add acpi=off and vga=ask to the kernel boot parameters, but now that the OS is present I want to be able to dismiss acpi=off so I can power the system off unattended (server is to be set up on an as-needed basis with WOL, physically placed in a basement).

With acpi=off the soft power signal does not respond. Are there any other kernel options I can use to limit ACPI (so the system can boot) but allow the system to turn itself off as well?

1

After a day with this, I found a few workarounds, with varying results.

  1. Swapping out acpi=off for nolapic allows the system to boot and power off, until I noticed that I was operating on only one core.
  2. Disabling "MPS Table Mode" in the BIOS[*] has the same outcome as option one, but with less kernel chatter.
  3. I tried the Debian Jessie (older) install disc, went into recovery mode to fire up a shell, and no kernel parameters were needed at all. /proc/cpuinfo showed both cores and poweroff worked.
  4. Apparently the core issue has been fixed in the 4.13 kernel. I did not get an opportunity to try this yet, but this may be my preferred option.

[*] http://forums.debian.net/viewtopic.php?f=10&t=134408

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.