0

One day running old 4.3 skype in openSUSE Tumbleweed accidentally got error:

> skype 
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", 
line 13: mismatched tag
Segmentation fault (core dumped)

Previously all worked just fine. Probably some OS update or whatever.

gdb skype output:

backtrace:

Program received signal SIGSEGV, Segmentation fault.
0xf358c2c1 in ?? () from /usr/lib/libexpat.so.1
(gdb) backtrace
#0  0xf358c2c1 in ?? () from /usr/lib/libexpat.so.1
#1  0xf3572617 in ?? () from /usr/lib/libexpat.so.1
#2  0xf3573850 in ?? () from /usr/lib/libexpat.so.1
#3  0xf3574ce3 in ?? () from /usr/lib/libexpat.so.1
#4  0xf3576398 in ?? () from /usr/lib/libexpat.so.1
#5  0xf357abdb in XML_ParseBuffer () from /usr/lib/libexpat.so.1
#6  0xf3d42b16 in ?? () from /usr/lib/libfontconfig.so.1
#7  0xf3d43039 in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#8  0xf3d430ce in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#9  0xf3d43260 in ?? () from /usr/lib/libfontconfig.so.1
#10 0xf35723f2 in ?? () from /usr/lib/libexpat.so.1
#11 0xf3573850 in ?? () from /usr/lib/libexpat.so.1
#12 0xf3574ce3 in ?? () from /usr/lib/libexpat.so.1
#13 0xf3576398 in ?? () from /usr/lib/libexpat.so.1
#14 0xf357abdb in XML_ParseBuffer () from /usr/lib/libexpat.so.1
#15 0xf3d42b16 in ?? () from /usr/lib/libfontconfig.so.1
#16 0xf3d43039 in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#17 0xf3d3544c in ?? () from /usr/lib/libfontconfig.so.1
#18 0xf3d356cd in ?? () from /usr/lib/libfontconfig.so.1
#19 0xf3d3570a in FcInitLoadConfigAndFonts () from /usr/lib/libfontconfig.so.1
#20 0xf3d284c6 in ?? () from /usr/lib/libfontconfig.so.1
#21 0xf3d284f8 in ?? () from /usr/lib/libfontconfig.so.1
#22 0xf51dbb9b in ?? () from /usr/lib/libQtGui.so.4
#23 0xf51514da in QApplicationPrivate::construct(_XDisplay*, unsigned long, unsigned long) () from /usr/lib/libQtGui.so.4
#24 0xf51517c0 in QApplication::QApplication(int&, char**, int) () from /usr/lib/libQtGui.so.4
#25 0x56a71a8a in ?? ()
#26 0x56a71864 in ?? ()
#27 0x5681246f in ?? ()
#28 0xf47077b3 in __libc_start_main () from /lib/libc.so.6
#29 0x5681fe8d in ?? ()

Removing /etc/fonts/conf.d/10-hinting-slight.conf causes error and crash in another (next) .conf file, etc. libexpat1 - is a XML Parser Toolkit. Is there a way to fix?

P.S. Now removed these .conf files with error, got another SEGFAULT:

(gdb) backtrace 
#0  0xf4775220 in tcache_get () from /lib/libc.so.6
#1  0xf3d4d922 in ?? () from /usr/lib/libfontconfig.so.1
#2  0xf3d4da3f in FcStrSetAdd () from /usr/lib/libfontconfig.so.1
#3  0xf3d4fcb0 in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#4  0xf3d500ce in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#5  0xf3d50260 in ?? () from /usr/lib/libfontconfig.so.1
#6  0xf35892bc in ?? () from /usr/lib/libexpat.so.1
#7  0xf3589ec0 in ?? () from /usr/lib/libexpat.so.1
#8  0xf3587f63 in ?? () from /usr/lib/libexpat.so.1
#9  0xf3588abc in ?? () from /usr/lib/libexpat.so.1
#10 0xf358c2eb in XML_ParseBuffer () from /usr/lib/libexpat.so.1
#11 0xf3d4fb16 in ?? () from /usr/lib/libfontconfig.so.1
#12 0xf3d50039 in FcConfigParseAndLoad () from /usr/lib/libfontconfig.so.1
#13 0xf3d4244c in ?? () from /usr/lib/libfontconfig.so.1
#14 0xf3d426cd in ?? () from /usr/lib/libfontconfig.so.1
#15 0xf3d4270a in FcInitLoadConfigAndFonts () from /usr/lib/libfontconfig.so.1
#16 0xf3d354c6 in ?? () from /usr/lib/libfontconfig.so.1
#17 0xf3d354f8 in ?? () from /usr/lib/libfontconfig.so.1
#18 0xf51e8b9b in ?? () from /usr/lib/libQtGui.so.4
#19 0xf515e4da in QApplicationPrivate::construct(_XDisplay*, unsigned long, unsigned long) () from /usr/lib/libQtGui.so.4
#20 0xf515e7c0 in QApplication::QApplication(int&, char**, int) () from /usr/lib/libQtGui.so.4
#21 0x56ab2a8a in ?? ()
#22 0x56ab2864 in ?? ()
#23 0x5685346f in ?? ()
#24 0xf47147b3 in __libc_start_main () from /lib/libc.so.6
#25 0x56860e8d in ?? ()
  • Does old Skype even work? I heard that since they have released new version, version 4 no longer works. omgubuntu.co.uk/2017/06/skype-4-3-linux-stop-working-july-2017 – kirill-a Nov 20 '17 at 14:26
  • @kirill-a it works, need to patch it: sed -i 's/4\.3\.0\.37/8.3.0.37/' /usr/bin/skype – Aleksey Kontsevich Nov 20 '17 at 14:45
  • 1
    if I disable Skype's AppArmor rules (and risk letting this monster roam free), it works again without the segfault. journalctl --follow clearly shows app armor rejecting read opens to /usr/share/fonts-config/font.avail/ (where symlinks from /etc/fonts/conf.d/ point to) the exact moment when skype crashes. – DrYak Dec 1 '17 at 16:47
  • @DrYak, strange it worked for me before with same apparmour. Yes, You are right works now with default skype profile from /usr/share/apparmor/extra-profiles/ which is even less rigorous than I had. And need to patch skype like I mentioned above. – Aleksey Kontsevich Dec 2 '17 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.