0

My pc has Kubuntu 17.04 and windows 10 setup with dual boot.

When i boot to kubuntu as soon as the login screen shows i hear high pitch coil whine sound from my pc.

I disabled all the power states on my bios (i know it can cause it). It didn't help.

whenever theres a little load on the cpu the noise stops.

Needless to say it doesn't happen on windows 10.

My specs:

  • cpu: core i5-2500k
  • mobo: Z68AP-D3

Any suggestions??

1

Well i found the answer to this problem.

I knew that some CPUs of Sandy Bridge family had coil whine issue when stepping down to C3 power state. That can be solved easily by disabling C3 power state from bios.

The thing is that for some reason kubuntu ignores this option in the bios.

The solution is to add this line intel_idle.max_cstate=1 to the file: /etc/default/grub

As explained in this post: https://askubuntu.com/questions/749349/how-to-set-intel-idle-max-cstate-1

Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.