3

I installed Debian Buster on a Dell Inspiron 5567. This is my soundcard:

inxi -A
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel Sound: ALSA v: k4.13.0-1-amd64

The laptop's speakers work fine, but I don't get sound out of headphones/speakers when plugged in; automute works though and pavucontrol shows sound directed through the headphones output (attachment follows).Pavucontrol recognises output through headphones I read some other posts on similar issues, but they don't apply in my case. The main reason is that I don't have an alsa-base.conf nor a asound.conf files (the first one is supposed to be on /etc/modprobe.d/ and the other one on /etc/). I checked the links posted on the third link above and I confirmed what I knew already: I only have one soundcard; it has a lot of virtual devices though; screencap follows.Many options for my only sound card

I downloaded and ran alsa-info.sh and I get the following error:pcilib: sysfs_read_vpd: read failed: Input/output error; I googled it and nothing useful came up (most of the posts refer to lspci). All my alsa level are correctly set on alsamixer, although I get a default card with just one level on execution of alsamixer:Home of alsamixer

Any ideas? Should I create alsa-base.conf and asound.conf? If so, what should be in them? Thanks in advance!

EDIT: I forgot to mention that headphones work well on a Sparky Linux (based on Debian Testing) live USB.

2

Two users on a Debian Facebook group provided the answer for this one. First I had to install libsamplerate0 and uncomment the lines

allow-module-loading
resample-method = src-sinc-best-quality
avoid-resampling

on the file /etc/pulse/daemon.conf; actually the first line has other sampling method by default, that's why it is necessary to install libsamplerate0. Then I had to create the file /etc/modprobe.d/alsa.conf with the single line

options snd-hda-intel model=headset-mic

and then restart alsa and pulseaudio services. Now audio works both on the internal speakers and on headphones/speakers plugged in the audio jack.

  • 1
    THIS helped me a lot. I am running Debian Stretch, kernel 4.18 bpo and today suddenly stopped pulseaudio playing to headphones, just speakers. Nothing helped (reinstalling alsa, pulse, removing config, reboots). Just this. I do not know why, but thanks :-) – Martin Oct 31 '18 at 17:11
  • Glad it helped, Martin. Cheers! – Óscar Guajardo Nov 1 '18 at 18:29
0

After the latest reinstallation of ArchLinux on my Laptop (ThinkPad T460s) a couple of days ago I had the same symptoms than you: Speakers worked, but no sound on the headphones although the output was shown as active and "playing" audio in pavucontrol; the same when not using pulse, but just ALSA with aplay.

Next I tried a Debian Live USB-Stick (Jessie, 3.16) and the linux-lts Kernel in Arch (4.9) and what do you know, headphones were working using these kernels. And the best thing: They stayed working again after I booted into the "new" reinstalled system!

If this behaviour repeats itself for me I'll let you know (and might open an issue on kernel.org if I'm certain it's the kernel and not just some faulty userspace component).

  • So you think it might be a kernel issue? – Óscar Guajardo Nov 28 '17 at 2:40
  • It could be, as (for me) it started after a significant change in kernel version. But at the same time all of userspace and as such potentially some firmware blobs got updated as well.When I have the time I'll try and see if I've got any firmware that wasn't installed before and – Daniel E. Nov 30 '17 at 7:38
  • ... you never know - might be a bug in the hardware that got triggered by the newer kernel. Also the problem went away when booting the system with an older kernel - but as I had no real methodology when I rebooted it's quite hard to track down exactly what I did to fix it now. – Daniel E. Nov 30 '17 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.