1

I used Rufus to burn Debian 9.2 NetInstall ISO to a USB. No matter what options I choose on Rufus, I always run into the same problem when installing Debian. When it gets to installing GRUB, it hangs at 16% on "Looking for other operating systems."

I even tried burning the ISO file to the USB on another computer running Debian, using dd. Same problem.

When the installation hangs, I press 'Ctrl + Alt + F4' to bring up the terminal. It showed an extremely fast scrolling of errors and messages. I used my iPhone to take slow-motion video of the terminal messages as they zoomed by.

Here are a few stills showing the messages and errors I get: https://imgur.com/a/kpNiq.

The errors seem to be about being unable to find certain directories? I'm on a Dell Inspiron 13 7000 Series laptop.

Why does the install hang? What do these errors means? How do I fix this and get on with the Debian installation?

  • 1
    I can't give you an answer to your specific case but in my experience Rufus frequently creates unbootable or corrupt usbs. – jdwolf Nov 20 '17 at 1:36
2

Looks like the ESP partition on your system disk is slightly corrupted: the directory entry /EFI/dell/logs has a pointer back to itself, creating an apparently infinitely deep directory tree. This is a relatively common problem on FAT-type filesystems. (The filesystem on the ESP partition is essentially FAT32.)

The installer is trying to search through all the directories on the ESP partition, but because of the corrupted directory, this search is stuck in an infinite loop.

You should try booting from the install media to rescue mode, identify the ESP partition and then run a filesystem check (fsck.vfat) on it. The filesystem check tool is likely to report a problem with either the /EFI/dell or /EFI/dell/logs directory. It might even suggest deleting the directory: deleting /EFI/dell/logs is probably fine, but you might want to recreate it afterwards, just to be sure.

In a rescue environment, the full path would be something like /target/boot/efi/EFI/dell/logs, as the root filesystem is mounted under /target while in rescue mode, and the ESP partition is mounted under /boot/efi while the system is running normally.

If the ESP filesystem is read-only in rescue mode, that's another indication that something is wrong with it. Typically ESP is the first partition on the first disk, or /dev/sda1. Run cat /proc/mounts in rescue mode to see the device name mounted to /target/boot/efi, then umount /target/boot/efi to unmount it, and then e.g. fsck.vfat /dev/sda1 to check it for errors.

  • The directory is on /dev/sda. I booted the USB into Rescue Mode and opened a shell in the installer environment. When I tried running ‘rm -rf target/EFI/dell/logs’, the terminal gave an error saying it’s a read-only directory. How can I remove the directory? – Username Nov 19 '17 at 20:47
  • The full path in the rescue environment should be something like target/boot/efi/EFI/dell/logs, as the ESP partition is usually mounted under /boot/efi and in rescue mode the root filesystem is mounted under target. – telcoM Nov 20 '17 at 9:30
  • I just saw your edit. When I ran cat /proc/mounts, here's what I see: i.imgur.com/JeFp0fi.jpg. I don't see any device mounted at /target/boot/efi. Also, while running the shell in rescue mode on /dev/sda1, I cannot execute fsck.vfat. The command is not recognized... Or I ran it wrong. – Username Dec 15 '17 at 19:07
  • Looks like the rescue mode is mounting a VFAT (that Linux filesystem type includes FAT32) onto just /target. That's probably the ESP. So you'd need to unmount that (generally never fsck a filesystem that is mounted) and then find a way to run a fsck command appropriate to FAT filesystems on /dev/sda1. The command name might also be fsck.fat or dosfsck: run ls /sbin/*fsck* while in rescue mode to look for likely candidates. – telcoM Dec 17 '17 at 1:52
  • I ran umount target. I ran ls /sbin/*fsck* and found that fsck.fat is what I wanted. I ran fsck.fat /dev/sda1. The console asked if I wanted to correct or delete corrupted files and folders. I typed my agreement into the console. I rebooted my machine and successfully installed Debian 9.3. – Username Dec 17 '17 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.