0

After executing apt-get update iam unable to install any packages.

# dpkg --configure -a

dpkg: dependency problems prevent configuration of libperl5.22:amd64:
 libperl5.22:amd64 depends on perl-modules-5.22 (>= 5.22.1-9ubuntu0.2); however:
  Version of perl-modules-5.22 on system is 5.22.1-9.

dpkg: error processing package libperl5.22:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of perl:
 perl depends on perl-modules-5.22 (>= 5.22.1-9ubuntu0.2); however:
  Version of perl-modules-5.22 on system is 5.22.1-9.
 perl depends on libperl5.22 (= 5.22.1-9ubuntu0.2); however:
  Package libperl5.22:amd64 is not configured yet.

dpkg: error processing package perl (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing package perl-modules-5.22 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Errors were encountered while processing:
 libperl5.22:amd64
 perl
 perl-modules-5.22

How to solve the issue?

4
  • 2
    did you try a apt install -f
    – Mike
    Nov 15, 2017 at 12:56
  • hi mike thanks for the reply.I have tried it and it works fine now.could u pls explain what exactly apt install -f will does.....
    – arun mohan
    Nov 16, 2017 at 7:21
  • attempts to fix any apt/dpkg errors that happen
    – Mike
    Nov 16, 2017 at 13:38
  • Did you ensure all packages are up to date? I usually run apt-get update followed by apt-get dist-upgrade to ensure all packages are up to date, that tends to resolve most of the dependency problems.
    – kasperd
    Nov 19, 2017 at 17:59

2 Answers 2

1

As error message says you can try reinstalling application using below command

sudo apt-get  install --reinstall perl-modules-5.22
1

Try to reinstall the package "perl-base".

apt-get --reinstall install perl-base

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .