8

I'm having an issue with gdebi, where it launches and loads the package I'm trying to install just fine, but whenever I click on "Install" it crashes and quits. I don't mind having to use dpkg -i while I'm sorting this out, the gui method is just easier when I don't really want to bother with the terminal approach.

I've already tried apt remove, apt autoremove and apt purge but each time I reinstall it, the same crash keeps occurring.

I'd be fine if you want to just suggest using another extremely lightweight gui pm installer, but I really don't want to launch the heavyweights like gnome-software, or appgrid.

If you'd like more info, please tell me what to copy/paste so you can see the error logs.

Anyone have any suggestions for me?

Thanks a lot.

1
  • Does gdebi crash when you install the package via terminal? Nov 19, 2017 at 7:55

6 Answers 6

5

This started happening to me in November also.

But GDebi is not actually crashing. If you run it in a terminal:

gdebi /path/to/.deb

It terminates with "must be root to install software packages"

Try:

sudo gdebi /path/to/.deb

I am accustomed to right-click .deb "Install with GDebi", but this currently does not work.

2
  • 1
    Running GDebi GUI as superuser helps. This can be done purely in GUI, open the .deb location in file manager, right click on the directory, "open as superuser" and then open the package in the newly opened window
    – RedClover
    Dec 21, 2018 at 17:40
  • Did you fix this problem?
    – goji
    Jan 7, 2019 at 6:04
3

The suggestion here to modify the .desktop file has the right concept, but if you can't get gksudo on your modern Linux installation then try the following:

Edit your gdebi.desktop file:

sudo gedit /usr/share/applications/gdebi.desktop

(Obviously, if you don't have "gedit", replace that with "nano" or whatever your preferred editor is.)

Now change the line:

Terminal=false

to:

Terminal=true

A minor quirk about this approach is you'll see a terminal window quickly flash and close but this should allow the application to prompt you for your password when you click "Install" which will grant the necessary permissions to actually begin installation.

1
  • nice trick, That worked for me on kali2020.2
    – abd3lraouf
    Jul 26, 2020 at 6:24
1

Run:

sudoedit /usr/share/applications/gdebi.desktop

Find the line:

Exec=gdebi-gtk %f

Make it read:

Exec=gksudo gdebi-gtk %f

SAVE the file.

That fixes it.

2
0

@Causeless Effect: Setting Terminal=true in the gdebi.desktop file was the solution for me too.

A minor quirk about this approach is you'll see a terminal window quickly flash and close but this should allow the application to prompt you for your password when you click "Install" which will grant the necessary permissions to actually begin installation.

On my system the 'minor quirk' is a bit different. When selecting a file in my file manager, right-click and select the option 'open with gdebi package installer', first a terminal window is opened, and in front of that the GUI of gdebi. Using the GUI works perfectly fine, and closing the GUI also closes the terminal window behind it.

0

It is not crashing as people said. It just can't install apps because you are not running with sudo.

So you can run:

sudo gdebi-gtk

Then, Gdebi with GUI will appear and you will be able to install .deb packages.

1
  • Welcome to the community. Considering there are already multiple answers with essentially the same info, to prevent this from being flagged as "low quality answer" I'd suggest you edit your answer to clarify how exactly this differs from the already-provided answers. I'd also recommend you read through the Help, sections about questions and answers to learn how things work. SE communities aren't discussion forums. Feb 4, 2023 at 10:49
-1

I had the same problem: make sure that the .deb package is not "read only" in its properties.

Worked for me.

1
  • Hi Daga, could you go into more detail the specific steps of making sure that package is not read-only?
    – Patrick
    Jul 24, 2020 at 17:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .