3

I use the following command line to set my system in English (installed in French) :

localectl set-locale LANG=en_US.utf8

However, when I boot into graphical mode, the desktop menu, directories names etc. are still in French.

The only way I can set everything in english is to use the graphical gnome menu "Applications > System tools > Settings > Region and Language".

Is there a way to change system language using command line as if I used the graphical menu?

EDIT :

In fact, my problem was coming from the fact that I was modifying through SSH with user root the system language but then loging through graphical console (workstation VM) under a standard user who has its language already defined. localectl works well but to define default language for a specific user, I must define $LANG in my .bashrc

3

To change the system language from the terminal , use the following line :

sudo system-config-language --text

Select your prefered language then validate.

Changes will take effect after the next reboot.

The --text option to avoid the prompt of the GUI.

  • I edited my question because I found out why I could'nt get the result I wanted. Your answer helped me a lot finding out why it couldn't work and also I didn't know system-config-language. I had to install it with yum by the way. – Pozinux Nov 18 '17 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.