2

This is my third Slackware 14.2 64 bits installation. I'm installing it now under a laptop with gpt partitions.

I will describe as best as possible the path I had to do with this installation.

Initially I had to overcome the issue that using dd to create the USB stick for installation was not booting from the pendrive. I had to use then the usbimg2disk.sh script.

Once I was able to boot from the USB I had to mount the pendrive manually as the USB was not detected when I was asked for source media. i.e. I did:

mkdir /os
mount /dev/sda1 /os

And then I selected "install from premounted directory" and used /os/cdrom0/slackware64

All the installation went fine but then I faced another issue, which I couldn't resolve yet. I tried with lilo and elilo options but the boot is still showing the grub2, which was there from the ubuntu 14.04 installed previously, with no options but the grub command line instead

I may mention that from BIOS setup I see as UEFI Hard Drive BBS Priorities Boot Option #1 which is [ubuntu], but not sure that should be an issue, as I have overriden the ubuntu partition already. However I'm not sure why the ubuntu tag is there and I don't see anyhow to change that.

The partitions I selected within the installation were:

/dev/mmcblk0p3      /        ext4
/dev/mmcblk0p4      /home    ext4

As I had only grub available I decided to learn some grub commands and was able to start slackware kernel with below commands:

grub> set root=(hd0,gpt3)
grub> linux /boot/vmlinuz root=/dev/mmcblk0p3
grub> initrd /boot/vmlinuz
grub> boot

I thought it was going to be a successful start but instead I got following kernel panic error:

RAMDISK: Couln't find valid RAM disk image starting at 0. VFS: Cannot open root device "mmcblk0p3" or unknown-block(0,0): error

Below screenshot shows the whole error Trace:

kernel panic error

So, how can I start Slackware 14.2 with grub commands? I may be missing something as I am new to grub commands.

The best solution I would be looking for is that lilo or elilo show at startup in order to start Slackware automatically. What can I do for lilo to show as boot loader?

  • When I do a lsblk I get following disks I guess are the bootloaders: mmcblk0boot0 and mmcblk0boot1 but I don't know how to mount such disks to check what's there. Normal mounting says wrong fs type. – Cedric Zoppolo Nov 18 '17 at 1:19
1

I can't answer the "lilo not appearing" part, although you don't want LILO if you are using GPT partitions, you need ELILO instead. In any case, without knowing exactly which parameters you entered for ELILO at install time, it is hard to know what went wrong. It has been a long time since I installed Slackware on anything but VMs...

The Kernel Panic looks related to the kernel, are you using the "generic" or the "huge" kernel? It is likely that you could install the OS because the installer uses the "huge" kernel, but then selected the "generic" kernel to boot.

The "huge" kernel contains each and every driver available, but the generic kernel doesn't even include most filesystem drivers, you must create an initrd (read the /boot/README file for instructions)

  • Using huge kernel gave same results. It seems the problem on grub is that the /dev/mmcblk* partitions are not detected. As I tried with tab for autocompletion from grub command line and no options appear. However /dev/sda1 appear but if I select such as root I still get same results... – Cedric Zoppolo Nov 18 '17 at 21:25
  • In the past few days I've seen several different threads posted on LinuxQuestions, and also several package updates for Slackware-current related to UEFI. Maybe the problem you are seeing is an actual issue with the installer or the boot process. I have not dealt with UEFI / GPT enough to suggest anything else. – AlvaroGMJ Nov 27 '17 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.