0

I am cross-compiling a library to an ARM arch.
So as an example, in Ubuntu 16, the error message in config.log after running configure was:

cc1 libstdc++.so.6: cannot open shared object file file does not exist.

After running sudo apt-get install lib32stdc++6, configure ran without errors.

So my question is, why does the compiler need x86 stdc++.6 when I was certain the library should come from arm.

I also checked ~/cross_compile/arm/usr/lib/libstdc++.so.6 the file is present

In case I am mistaken, how am I supposed to know which one should I be looking for?

UPDATE: Added inherited configure params

Configured with: ../configure --srcdir=.. --build=i686-pc-linux-gnu --enable-cheaders=c --with-as=arm-unknown-nto-qnx8.0.0eabi-as --with-ld=arm-unknown-nto-qnx8.0.0eabi-ld --with-sysroot=/opt/qnx800/target/qnx6/ --disable-werror --libdir=/opt/qnx800/host/linux/x86/usr/lib --libexecdir=/opt/qnx800/host/linux/x86/usr/lib --target=arm-unknown-nto-qnx8.0.0eabi --prefix=/opt/qnx800/host/linux/x86/usr --exec-prefix=/opt/qnx800/host/linux/x86/usr --with-local-prefix=/opt/qnx800/host/linux/x86/usr --enable-languages=c++ --enable-threads=posix --disable-nls --disable-tls --disable-libssp --disable-libstdcxx-pch --enable-libmudflap --enable-libgomp --enable-__cxa_atexit --with-gxx-include-dir=/opt/qnx800/target/qnx6/usr/include/c++/4.8.3 --enable-shared --enable-multilib --with-bugurl=ttp://www.qnx.com --enable-gnu-indirect-function --enable-stack-protector --with-float=softfp --with-arch=armv7-a --with-fpu=vfpv3-d16 --with-mode=thumb CC=i686-unknown-linux-gnu-gcc LDFLAGS='-Wl,-s ' AUTOMAKE=: AUTOCONF=:

  • 1
    Are you sure you told configure to cross-compile? – Ignacio Vazquez-Abrams Nov 17 '17 at 16:51
  • @IgnacioVasquez-Arams Yes, i have a bash script where i set custom compiler, linkers and flags, then call configure with --host=arm-unknown-xxx-xxx.eabi – J11 Nov 17 '17 at 17:00
  • host? Not target? – Ignacio Vazquez-Abrams Nov 17 '17 at 17:04
  • Just updated the question with the parameters. – J11 Nov 17 '17 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.