3

I just installed Cent OS 7. Everything is working fine except for Wireless Network.

I use a Broadcom BCM 4312 Wireless Chipset for which i installed driver using the method wl-kmod

After the installation, Wifi option poped up in the GUI, which was not visible earlier.

The issue now is that Wireless networks are not getting listed.

Please suggest what to do next

I am very new here hence unable to provide required information

For your reference,

[Brijesh@localhost ~]$ nmcli general status
STATE      CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
connected  full          enabled  enabled  enabled  enabled


Brijesh@localhost ~]$ nmcli connection show
NAME                UUID                                  TYPE            DEVICE      
Wired connection 1  3c8886b9-3ad3-3d45-a3ca-a3d422c1fa0d  802-3-ethernet  enp0s29f7u3 
virbr0              36874c1e-52fc-48c2-af15-8feb6075b741  bridge          virbr0      
enp9s0              f67d6520-7d34-4eb3-a7d9-6258210bfb77  802-3-ethernet  --    

[Brijesh@localhost ~]$ nmcli device status
DEVICE       TYPE      STATE         CONNECTION         
virbr0       bridge    connected     virbr0             
enp0s29f7u3  ethernet  connected     Wired connection 1 
wlp12s0      wifi      disconnected  --                 
enp9s0       ethernet  unavailable   --                 
lo           loopback  unmanaged     --                 
virbr0-nic   tun       unmanaged     -- 

Screenshots:

enter image description here enter image description here enter image description here

Please Sugggest what need to be done

I am at my wits end trying to resolve this since a week

  • Please add the output of rfkill list. You can edit here – GAD3R Nov 18 '17 at 9:19
  • 1
    As requested, pls find the requested output [Brijesh@localhost ~]$ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no – Brijesh Ganapathy Nov 18 '17 at 10:15
1

I believe the firmware might not be getting loaded. The device can still appear as a network adaptor even if the firmware didn't load properly. What's the output of dmesg | grep firmware? If you see anything mentioning a failure to load firmware, you'l likely need to install your distro's linux-firmware-extra package.

The other cause may be the device has it's transmitter disabled. Check all hardware and software wireless power switches. I can't advise where to look on that because I'v never used WiFi on CentOS, or CentOS very much in general.

  • Than you for your kind reply. As suggested, i ran "dmesg | grep firmware" it didnt return any information. – Brijesh Ganapathy Nov 18 '17 at 6:38
  • The contents of the file can be viewed here. : drive.google.com/file/d/1qxMeMiKVJZ_FIaenVXQ5BuqpwJ5GI2XL/…. – Brijesh Ganapathy Nov 18 '17 at 6:55
  • there is no physical switch to turn on Wireless. Thank you @TheNH813 – Brijesh Ganapathy Nov 18 '17 at 6:57
  • I just found out that the hardware switch, which is an alternate to one of the function key was turned on which disabled Wireless. I failed to notice this since i assumed it only worked on windows. I am replying via wireless. Thank You for your support – Brijesh Ganapathy Nov 18 '17 at 19:14
  • 1
    @BrijeshGanapathy If this answer solve your problem , do not forget to accept it. – GAD3R Nov 20 '17 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.