0

Okay, I have looked at many posts and threads and haven't found a solution. So I am running x64 Debian. I installed Nvidia drivers from Nvidia's website by running a .run file. Now, I tried to install Steam so I tried

Sudo apt install steam 

I even tried hitting [TAB] after to see if it had a different name but it was nowhere to be found. So I downloaded a .deb file from the website and tried running it with

Sudo dpkg -i steam_latest.deb

but it installed and gave me an error:

Failed to parse arguments: Option "--disable-factory" is no longer supported in this version of gnome-terminal.
Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Running Steam on debian 9 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
Installing breakpad exception handler for appid(steam)/version(1509425745)
Installing breakpad exception handler for appid(steam)/version(1509425745)   
Installing breakpad exception handler for appid(steam)/version(1509425745)
Failed to load steamui.so - dlerror(): libGL.so.1: wrong ELF class: ELFCLASS64
Installing breakpad exception handler for appid(steam)/version(1509425745)
Installing breakpad exception handler for appid(steam)/version(1509425745)
[2017-11-15 10:42:19] Startup - updater built Oct 30 2017 19:09:32
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2017-11-15 10:42:19] Checking for update on startup
[2017-11-15 10:42:19] Checking for available updates...
[2017-11-15 10:42:19] Download skipped: /client/steam_client_ubuntu12 version 1509425745, installed version 1509425745
[2017-11-15 10:42:19] Nothing to do
[2017-11-15 10:42:19] Verifying installation...
[2017-11-15 10:42:19] Performing checksum verification of executable files
[2017-11-15 10:42:19] Verification complete
[2017-11-15 10:42:22] Shutdown

So it wouldn't run. I have TeamViewer installed which is also an i836 app and it runs so I don't think it is a problem with Multiarch. I asked on Reddit and a guy said it was probably a graphics card driver error so I tried to

sudo apt install nvidia-driver 

Which was found but it game me this error

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

Naturally, I tried "sudo dpkg --configure -a" but I get this

Setting up nvidia-installer-cleanup (20151021+4) ...

WARNING: The '--no-runlevel-check' option is deprecated:  nvidia-installer will
     ignore this option.


Welcome to the NVIDIA Software Installer for Unix/Linux

Detected 8 CPUs online; setting concurrency level to 8.

If you plan to no longer use the NVIDIA driver, you should make sure that no X
screens are configured to use the NVIDIA X driver in your X configuration file.
If you used nvidia-xconfig to configure X, it may have created a backup of your
original configuration. Would you like to run `nvidia-xconfig
--restore-original-backup` to attempt restoration of the original X
configuration file?
  [default: (N)o]: 

Then I type y and hit enter and it freezes. even after an hour it is not done and the progress bar that pops up doesn't move. Is it my graphics? How can I completely remove everything and reinstall to start from the begining of just my graphics card drivers without reinstalling my OS?

This is the output of "glxinfo | grep render"

direct rendering: Yes
OpenGL renderer string: GeForce GTX 1060/PCIe/SSE2
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NVX_nvenc_interop, 
    GL_NV_compute_program5, GL_NV_conditional_render, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NV_path_rendering_shared_edge, GL_NV_pixel_data_range, 
    GL_NV_shader_thread_shuffle, GL_NV_stereo_view_rendering, 
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_NVX_nvenc_interop, 
    GL_NV_compute_program5, GL_NV_conditional_render, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NV_path_rendering_shared_edge, GL_NV_pixel_data_range, 
    GL_NV_shader_thread_shuffle, GL_NV_stereo_view_rendering, 
    GL_EXT_raster_multisample, GL_EXT_render_snorm, GL_EXT_robustness, 
    GL_NV_conditional_render, GL_NV_conservative_raster, 
    GL_NV_packed_float_linear, GL_NV_path_rendering, 
    GL_NV_path_rendering_shared_edge, GL_NV_pixel_buffer_object, 
    GL_NV_stereo_view_rendering, GL_NV_texture_array, GL_NV_texture_barrier, 
    GL_OES_fbo_render_mipmap, GL_OES_geometry_point_size, 
  • Does TeamViewer use direct rendering ? I doubt it. You are missing direct rendering support for i386. Have you tried installing the two packages steam said were missing ( libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386) ? Also, what is the output of glxinfo | grep render ? – thecarpy Nov 15 '17 at 22:08
  • It was too big for a comment I am pasting it in as an edit – Trevor Vance Nov 16 '17 at 3:27
0

I will first attempt to explain what was happening, to the best of my knowledge ;-). Then provide a few user-friendly tips for Debian users.

Why did you initial command not work ?

Sudo apt install Steam 

The package is actually called "steam" (all lower case), it is a i386 package, so to install it, you issue the following:

sudo apt-get install steam:i386

This should have, in theory, pulled all dependencies and all should have been fine.

How do I know, I do not have steam installed ? Google ;-)

To find a package in Debian, the easiest and friendliest I found is the following Google search:

<package> site:packages.debian.org

In this case:

Steam site:packages.debian.org

This is one result: "https://packages.debian.org/stretch/steam", on the top I can see in which repository it is (non-free), on the bottom of that page, I can see for which architectures steam is available, namely, "i386" only.

Package libgl1-mesa-dri:i386 needs to be installed 
Package libgl1-mesa-glx:i386 needs to be installed 
Running Steam on debian 9
64-bit STEAM_RUNTIME is enabled automatically Pins up-to-date! Error:
You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1

Here, apt is telling you that steam needs libgl1-mesa-dri:i386 and libgl1-mesa-glx:i386 and later, it is also telling you exactly which library is needed:

libGL.so.1

Again, how would I easily find out how to install that library ? Google, again, is your friend:

libGL.so.1 site:packages.debian.org

I click on one of the results and I see libGL.so.1 is provided by:

libgl1-mesa-glx:i386

Actually, I did not have to google as I know libgl1 (in the package name) is libGL.so.1, but that was just a bit lucky.

Now, apt is smart, that is exactly the package apt complained about was missing ;-).

How can I completely remove everything and reinstall to start from the begining of just my graphics card drivers without reinstalling my OS?

First of all, you need to prepare a text file with the commands you want to execute because we are going to use the console.

Place the following in a text file, store it in your home directory in a file called mycommands.txt:

sudo apt-get remove steam
sudo service gdm3 stop
sudo nvidia-uninstall
sudo apt-get install nvidia-driver
sudo apt-get install steam
echo done

Hit Ctrl+Alt+F2, you should now be on tty2, enter your username and password. Next, we source our text file to execute the commands (it will ask for your sudo password):

. mycommands.txt

Notice the dot (important). If you placed the file on your desktop, for example, you would have to issue:

. ~/Desktop/mycommands.txt

Accept the Steam license, all should be fine, I hope.

  • Thanks, I did not capitalize steam when I did the search I just accidentally did when I put it in here. I tried making and running your script but it still froze at the same spot. So it never got past nvidia-uninstall. I did run that in tty2 – Trevor Vance Nov 16 '17 at 19:58
  • I ran it in recovery mode and it is fixed now. Thank you so much!!! – Trevor Vance Nov 16 '17 at 20:03
0

It is probably some graphic card versions do not supported. Like mine 820M. I am using Nouveau instead of nvidia and it works fine most of the games and apps.

  • That might be the case. How can I change it so I can test it? – Trevor Vance Nov 16 '17 at 3:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.