0

I keep seeing similar question regarding drivers on Linux for both NVIDIA and ATI that is impossible to keep at the same time but there is no solution for my problem. I have installed Linux Mint on External SSD disk 256GB so I could freely jump from one computer to another and keep my settings/programs/data in one place. I have installed Linux and drivers on computer which has NVIDIA graphic card. Today I have tried to connect with another one. All was fine till I notice that resolution and graphic quality is very low. The other computer has ATI RADEON graphic card.

Is it possible to keep drivers for both cards so Linux we automatically choose the correct one when I connect to another computer? I know there is a lot of play with uninstalling and installing drivers when I connect to 3rd or 4th computer in situation when there will be older or newer NVIDIA/RADEON but still I want to keep it that way.

Alternative solution: quick way to uninstall drivers from latest used computer and install new drivers to new computer?

OR

how I could switch between drivers?

Any ideas are appreciated.

  • try this: when you boot on one PC, edit the kernel commandline from the bootloader and add modprobe.blacklist=modulename (where modulename is the other PC's video driver module). see if that boots properly. if that works, you can look into writing separate bootloader options for each PC that includes the correct blacklist parameter. source – quixotic Nov 14 '17 at 23:09
  • Thanks! Works like a charm. Whenever I change blacklist to nouveau or radeon it load kernel correctly, but to work it every time when I boot Linux I have to do it manually. Now I have to create separate entry in GRUB2 with same kernel and modify command line so it will blacklist module whenever I choose first or second entry. I could not find any reliable source how to do that. Do you have any ideas? – Dominik Ruczajewski Nov 18 '17 at 22:52
  • I managed to do that with grub_customizer. Now have same kernel with 2 entries. Thanks once more. – Dominik Ruczajewski Nov 18 '17 at 23:31
  • i haven't used grub in a number of years, so i can't suggest another way (better or worse!) than what you've found. feel free to post it as an answer and accept it! – quixotic Nov 19 '17 at 3:05
0

I have managed to do it with little help from @quixotic.

For those who will look to similar result as me.

Install grub_customizer and create entry copy of the main kernel which you want to use. Then edit entry and add modprobe.blacklist=module_name (type radeon if you want to use NVIDIA card drivers or nouveau if you want to use ATI card drivers). I have added it as first line.

When you will be working on PC with ATI RADEON graphic card radeon open source drivers gives a very bad graphic performance so you will need to modify xorg.conf and xorg.conf.d for better tunning. Please refer to Performance tuning link to ArchWiki.

I hope it will help others :)

EDIT: I am using Linux Mint 18.2 Cinnamon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.