3

I've already looked at three sources (1, 2, 3) with no luck. I've tried launching urxvt -fn 'xft:DejaVu Sans Mono:size=9' and urxvt -fn xft:FontAwesome. A lot of characters show up properly, but characters like "नमस्ते" show up as squares only:

Unicode rendered in urxvt

Strangely, the IntelliJ IDEA configuration says it's using the same font and there the same string displays fine:

Unicode rendered in IDEA

Does IDEA use some sort of fallback font for unknown glyphs, or is my configuration wrong?

$ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
$ xrdb -query
URxvt.background:   gray5
URxvt.color0:   Black
URxvt.color1:   Red3
URxvt.color10:  SpringGreen1
URxvt.color11:  Yellow
URxvt.color12:  RoyalBlue1
URxvt.color13:  Magenta
URxvt.color14:  Cyan
URxvt.color15:  White
URxvt.color2:   Green3
URxvt.color3:   Yellow3
URxvt.color4:   Blue3
URxvt.color5:   Magenta3
URxvt.color6:   Cyan3
URxvt.color7:   AntiqueWhite
URxvt.color8:   Grey25
URxvt.color9:   Red
URxvt.font: xft:DejaVu Sans Mono:pixelsize=42
URxvt.foreground:   gray80
URxvt.scrollBar:    false
URxvt.scrollTtyKeypress:    true
URxvt.scrollTtyOutput:  false
URxvt.scrollWithBuffer: true
URxvt.secondaryScreen:  true
URxvt.secondaryScroll:  false
$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fedfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/OTF/,built-ins
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled
  • This is almost always a font problem. Here's what works for me with xterm: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1. Other sizes of the same font don't work. – Satō Katsura Nov 14 '17 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.