I have been using linux with a Lenovo Yoga 3 Pro for two years now, and I have quite a pain in the a** since nearly 1 year: my touchpad randomly freezes for no apparent reasons.

After 2 months or so, I discovered the kern.log and found that each time the touchpad freezes the system prints these two lines:

Nov 10 13:26:20 yoga kernel: [58421.564376] i2c_designware INT3432:00: i2c_dw_handle_tx_abort: lost arbitration
Nov 10 13:26:20 yoga kernel: [58422.586706] i2c_designware INT3432:00: controller timed out

When it happens, I am forced to shutdown the laptop COMPLETELY. Switching user or logging out simply does not solve anything. Sometimes I can have the problem only once a week, sometimes I want to kill myself as it happens 10 times in a day...

It seems to me that it can come from a static electricity problem right on the touchpad (hardware), but well, I thought I might ask here before throwing my laptop to the trash: who knows, maybe a some Linux Yoda could help my Yoga :P

I am done looking for solutions to prevent the freeze: I am asking here a solution that would let me re-use the touchpad without complete shutdown.

Things to note:

  • I use Ubuntu 16.04 since 4 months, but before that I was using Linux Mint 18 and before I used to have Linux Mint 17.3 : The problem happened on all 3 OS.
  • The problem can occur in any fashion: it is NOT correlated to any program use and/or performance (if it is, it can only be a pre-installed Linux program as the problem happened right after clean install)
  • I oddly found that the mouse can freeze when I switch position myself (say I am on my sofa reading a blog like 1 hour, then I decide to stand and put the laptop on a table: boom ! it freezes, like if it knew it's time to go to bed or something...)
  • According to bugzilla.redhat.com/show_bug.cgi?id=1275718 and lists.ubuntu.com/archives/kernel-team/2016-March/074624.html, it may have been fixed (or just partially fixed) in a more recent kernel. – Teresa e Junior Nov 14 '17 at 6:04
  • Thanks ! So what do you suggest I should do ? Update the kernel ? – Jona Rodrigues Nov 14 '17 at 15:11
  • You may not be able to get a very recent kernel pre-compiled for 16.04. If I were you, I would test the behaviour of the touchpad by running a recent LiveCD for some hours (either Ubuntu 17.10 or Fedora 27). If it works well, you can either install it, which is the easiest way, or you can recompile the newest kernel for your Ubuntu 16.04, which is not very difficult if you follow a recent tutorial! – Teresa e Junior Nov 14 '17 at 17:29
  • Thanks for your reply ! I run out of USB keys to test this using LiveUSB. I am buying a new USB flash to host the OS and try your solution. Whenever I receive it I will post my results. Thanks again for your time. – Jona Rodrigues Nov 16 '17 at 16:54
  • I finally got it, sorry for the delay... Same issue happens with 17.10. After a lot of underground search I finally reached that discussion and found that I can regain mouse control by... moving the yoga screen... very odd. So I guess this is a hardware problem. – Jona Rodrigues Dec 17 '17 at 19:33

I've been having this issue too! It is infuriating. I have a Yoga 3 11.6

I've tried underclocking the i2c bus, but that doesn't seem to have done anything.

When it happens to me, sometimes removing and reinserting the elan_i2c kernel module will fix it. If that doesn't work, then removing the modlule, closing the laptop lid, waiting a few seconds, opening it again, and re-inserting the module seems to work.

  • Did you by any chance tried to open the cover to see what's in it ? It's been 1 month I run without much issue after I purchased a no. 5 Torx and air-cleaned the Touchpad area. Seems to make the trick so far... – Jona Rodrigues Jan 7 '18 at 4:06
  • Interesting, I have also tried cleaning the area but it didn't seem to make much difference. I'll try being more thorough and see what happens. – Retr0id Jan 7 '18 at 16:35
  • 1
    Finally a solution! The command in my case (also Yoga 3) was sudo modprobe -r i2c-hid && sudo modprobe i2c-hid. – Carlos Pinzón May 7 '20 at 18:59

Just in case someone comes here with the same situation. The problem is not fixed as it is a Hardware problem. According to a lot of people in this forum's thread it seems like the Lenovo Yoga suffers from bad hardware finition.

In fact, a lot of users found a "solution" to their problem by adjusting screws, or changing wifi card etc...

In my case I found that I can regain control of the mouse by either:

  • generating static electricity on the touchpad: by maintaining strong pressure while frenetically moving the finger on the touchpad
  • moving the screen while moving finger on the touchpad

Oddly, the mouse comes back until next freeze. So this is not a solution to the original problem, but it is a commodity fallback to prevent restarting the computer in the middle of a work...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.