1

How does one search for certain manpages (such as http://linux.die.net/man/5/attr)? Trying:

man attr

and

man -K attr

don't seem to work.

Any ideas why?

  • man -k keyword # works for me. although check for MANPATH variable.. man -L – Nikhil Mulley Jun 10 '12 at 14:51
  • do you think it's possible that I don't have this manpage? I'm on a fresh install of Debian 6.04. – Soyuz Jun 10 '12 at 15:07
  • "Doesn't work"? Please be more specific. What exactly happens? Do you get an error? – Mikel Jun 10 '12 at 21:57
  • It just can't find it, but turns out I needed the attr package and not just libattr, so it works now! – Soyuz Jun 11 '12 at 15:55
1

You can view it like this:

man 5 attr

For a full explanation, take a look here

  • I tried that as well. Is it possible that I actually don't have that specific manpage? (Edit: This refers to a fresh text install of Debian 6.04) – Soyuz Jun 10 '12 at 15:02
  • On Debian the attr command and the related man pages are in the attr package. Is it installed? – manatwork Jun 10 '12 at 16:12
  • You're right, for some reason I thought the manpages were the libattr package, but installing attr fixed that. Thanks! – Soyuz Jun 10 '12 at 16:32
  • apt-file or packages.debian.org can tell you which package provides a given file. e.g. packages.debian.org/… – Mikel Jun 10 '12 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.