0

I have been trying to configure my raspberry in order to have a printer server. I have a Hp printer which is connected through USB to my raspberry pi. The first part of this project is to configure printer with the RPi, and every website (also here) I found indicate that is needed to install cups using apt-get.

The point is that I have dependency errors, I haven't been able to solve it.

What I have try:

  1. Remove and install again: I remove all packages of cups and then try to install it.
  2. I have made sudo apt-get update && upgrade (I lost the count of times I have repeat it).
  3. I upgrade the OS: I was working in Raspbian Wheezy and I upgrade to Raspbian Jessie.

How could I go on with this?

I have not try to clear my sd and start from another Raspbian installation from nothing, because I use my RPi to control another stuff in my home, so I prefer not to go ahead this solution if there is any other chance to solve this issue.

Thanks in advance,

  • Welcome to U&L , please edit your question here . Add the error to your question ,also the cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/* – GAD3R Nov 13 '17 at 14:20
  • Thanks for the advice. I will edit today, tonight whem I arrived home. – César Hoyos Nov 14 '17 at 8:14
0

This command:

sudo apt-cache show cups | grep -i dep

Gives these dependencies:

libavahi-client3 (>= 0.6.16)
libavahi-common3 (>= 0.6.16)
libc6 (>= 2.16)
libcups2 (= 2.1.3-4)
libcupscgi1 (>= 1.4.2)
libcupsimage2 (>= 1.4.0)
libcupsmime1 (>= 1.4.0)
libcupsppdc1 (>= 1.4.0)
libgcc1 (>= 1:3.5)
libstdc++6 (>= 4.3.0)
libusb-1.0-0 (>= 2:1.0.8)
debconf (>= 1.2.9)
debconf-2.0, libc-bin (>= 2.13)
cups-core-drivers (>= 2.1.3-4)
cups-daemon (>= 2.1.3-4)
poppler-utils (>= 0.12)
procps
ghostscript (>= 9.02~)
lsb-base (>= 3.2-14~)
cups-common (>= 2.1.3-4)
cups-server-common (>= 2.1.3-4)
cups-client (>= 2.1.3-4)
cups-ppdc
cups-filters (>= 1.0.24-3~)

Maybe you could try installing these? Hope this works.

  • Thanks for the feedback. When I try this, I will give more information about which of this packages are the ones that return this dependency error. – César Hoyos Nov 13 '17 at 11:59
  • Sorry I haven't posted. Really thanks for your answer. I finally achieve this to work with that dependencies. Now I am having troubles with hplip, but I am currently solving it, thank you. – César Hoyos Nov 25 '17 at 15:43
  • Glad to be of help! Could you give me a plus one? – Robert Alers Nov 28 '17 at 15:19
  • I tried, but I cannot cause I am nobbie and have less than 15 reputation :( – César Hoyos Nov 28 '17 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.