I can't mount my e-reader. Here's what I tried:

I connected my e-reader to the computer via usb. dmesg tells me the OS (debian 9) recognized the device and assigned /dev/sdb and /dev/sdc to it:

usb 1-6: new high-speed USB device number 6 using ehci-pci
[ 2023.922301] usb 1-6: New USB device found, idVendor=15a2, idProduct=0c01
[ 2023.922306] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2023.922309] usb 1-6: Product: 623
[ 2023.922312] usb 1-6: Manufacturer: Papyre
[ 2023.922315] usb 1-6: SerialNumber: 0123456789ABCDEF
[ 2023.930149] usb-storage 1-6:1.0: USB Mass Storage device detected
[ 2023.930323] scsi host4: usb-storage 1-6:1.0
[ 2024.961442] scsi 4:0:0:0: Direct-Access     Papyre   623              0100 PQ: 0 ANSI: 2
[ 2024.963410] scsi 4:0:0:1: Direct-Access     Papyre   623              0100 PQ: 0 ANSI: 2
[ 2024.964818] sd 4:0:0:0: Attached scsi generic sg2 type 0
[ 2024.966505] sd 4:0:0:1: Attached scsi generic sg3 type 0
[ 2025.001429] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 2025.035684] sd 4:0:0:1: [sdc] Attached SCSI removable disk

I tried to mount /dev/sdb with mount /dev/sdb /media/ereader getting this error:

 mount: no se ha encontrado ningún medio en /dev/sdb

Which roughly translates to:

mount: no medium found in /dev/sdb

I also tried with the -t vfat option, and repeated the process with /dev/sdc, with the same result.

In case you ask, here's the output of sg_map:

/dev/sg2  /dev/sdb
/dev/sg3  /dev/sdc 

And fdisk -l /dev/sdb (my own translation):

fdisk: can't open /dev/sdb: Medium not found

Output from lsblk -f:

NAME   FSTYPE LABEL          UUID                                 MOUNTPOINT
├─sda1 ext4                  8110f71a-b0eb-4968-bdf2-2c398a4e056c /
├─sda2 ext4                  09be5f99-740b-4892-8607-a87d27953110 
├─sda3 ext4   linux_archivos 16a84f16-bca0-42e6-810e-34851fbcb0a1 /media/linux_archivos
└─sda4 swap                  ea2997b9-6401-424b-a5ea-487f6996c56f [SWAP]

Output from file /dev/sdb:

/dev/sdb: block special (8/16)

Output from file /dev/sdc:

/dev/sdc: block special (8/32)

Output from file -s /dev/sdb:

/dev/sdb: writable, no read permission

Output from file -s /dev/sdc:

/dev/sdc: writable, no read permission
  • 1
    So you get two USB storage devices, but no partition table, and Linux can't identify any file system. Please edit question with output of file /dev/sdb and file /dev/sdc (sometimes file can recognize formats the kernel can't). Last resort is hexdump -C /dev/sdb | less (or sdc), and see if you can make sense of it.
    – dirkt
    Commented Nov 13, 2017 at 7:49
  • What does lsblk -f give you?
    – Mio Rin
    Commented Nov 13, 2017 at 17:02
  • Please add the -s option to your file calls, like file -s /dev/sdc. You may need to run this as root, depending on permissions. Doesn't your ereader device export its empty memory card slot as sdb? That would explain the "no medium" error messages. Commented Nov 22, 2017 at 23:37
  • If you want the actual error message in English (well, technically, untranslated) you can do, for example: LANG=C your_command' instead of simply your_command`. Commented Apr 2, 2023 at 18:14

2 Answers 2


I had the same problem. At the end I discovered I was connecting my old e-reader to the SS-USB port. I changed it to the only simple USB port my laptop has and it worked like a charm!

  • 1
    Welcome to U&L! This doesn't sound like it would fix the problem described, but without knowing the exact hardware it's difficult to be certain. Were you definitely getting the same symptoms that the OP had (devices created OK, then the "no medium found" error) before applying this fix?
    – JigglyNaga
    Commented Dec 20, 2018 at 16:49
  • Negative. SS vs USB 2 doesn't make a difference on my 2012 laptop with a memory stick showing all the symptoms (fdisk medium not found, lsblk -f not showing it, file -s saying no read permission) Commented Aug 21, 2020 at 18:15
  1. check common fdisk -l
  2. what about sdc ?
  3. don't forget to check device status simultaneously on you e-reader itself (e.g. Data transfer/Charging/Media Access or so).
  4. needless to say root privilege is required
  • fdisk -l doesn't mention sdb nor sdc. Tried commands in the question for sdc, same results. All commands were run with root privilege. The e-reader seems to be stuck, can't even turn it off.
    – nico
    Commented Nov 12, 2017 at 23:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .