0

I am running an openSUSE leap 42.2 64 bit os on my laptop. I was trying to install some packages including nautilus-dropbox, so I added the packman repo. After zypper update, there were some packages that couldn't be updated because of repo's conflicts. So I tried to install them. At some point one packages was failed to be installed. Then when I am running any zypper command I am getting this error:

Target initialization failed.
Failed to cache rpm database (1).

What does this mean? And how can I fix it?

I checked df -h / and I was surprised to see that the root partition occupies 31G on my disk that 100% used space!

Is it possible that dropbox occupies space on my root / partition?

  • Though not the problem in this case, the same message can result from a corrupt package database. At suse.com/documentation/sles11/book_sle_admin/data/…, in section 6.1.8, Troubleshooting we see that one can refresh and rebuild the database with zypper refresh -fdb, and that solved my problem when I had the above message. – PJTraill Mar 28 '18 at 13:28
0

As you stated your root partition has no space left. Clean up to get some space on it and try it again. Have a look in /tmp /var/tmp /var/log for things you don't need any more. Additionally check if your /home directory is also in the root partition. If yes, dropbox could take the space on your root partition.

  • df -h returns /dev/sda6 47G 8.0G 39G 18% /home and on the other hand /dev/sda5 31G 31G 64K 100% / – Hipparkhos Nov 12 '17 at 21:53
  • du -sh .snapshots returns : 698G .snapshots What is this directory? – Hipparkhos Nov 12 '17 at 21:55
  • Is it safe to clean the directories /tmp /var/tmp and /var/log ? – Hipparkhos Nov 12 '17 at 22:06
  • Ok I deleted some snapshots and it worked! :) – Hipparkhos Nov 12 '17 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.