0

I recently installed LUKS encrypted Linux Mint 18.2 onto an SSDD at the time of install the it was the only disk present. Then I reattached my Windows 7 disk which is also encrypted using veracrypt. The Linux Mint disk is the first in the boot order. So I tried to customize the and update the grub menu , using a method that worked for me on a unencrypted install of mint, by doing the following;

1) sudo nano /etc/grub.d/40_custom

adding then this;

menuentry "Next in Boot Sequence" {
    exit
}

Save and close.sud

2) sudo update-grub

After that I get this error message;

Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
done

Does anyone know how to fix this or have any alternative booting strategies?

3
  • That's not an error, it's a warning. Consider posting the final, generated Grub configuration. Nov 14 '17 at 17:02
  • Sure what is the file path for that again? Nov 14 '17 at 17:06
  • On MBR systems it's something like /boot/grub/grub.cfg. Nov 14 '17 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.