3

I set up a NanoPi Neo 2 with OpenMediaVault (Debian Jessie) as its OS and have an hdd attached to it (the OS is on an SD card). When I now copy my data from my external hard drive onto my system with rsync -avP --checksum [source] [dest] and check back if everything went well with diff -r [source] [dest], it still tells me that some files differ. That happens even after repeating the procedure several times and even if I delete the differing files according to diff and resyncing everything.

So my question is: is this a normal behaviour and nothing to worry about or is my (new) hard drive on the system somehow faulty and therefore the new files get corrupted quickly after (hopefully correct) transfer with rsync?

  • It might be cool to see if you could get a minimal example that reproduces this issue. Pick one of the files where diff and rsync disagree and then try rsyncing just that one file to make sure you still get conflicting results. Then start shrinking that file until the conflict disappears (e.g. using head -c to grab the first n bytes. Alternatively, start small and work your way up until the problem occurs. – igal Nov 12 '17 at 15:53
  • To make that clear: After every rerun, diff tells me that other files are different than the last time... – BUFU Nov 13 '17 at 21:30
  • So there are files that appear to be different on one run (according to diff) and then appear to be the same on the next run? – igal Nov 13 '17 at 21:33
  • @igal: yes, exactly. but on the next run other files are claimed to be different.... oh, and btw: I have some photos for example and when I copy them back to my laptop, they open perfectly and I cannot see any problems with the files that are apparently different – BUFU Nov 14 '17 at 2:37
  • Have you tried rsyncing a single file (repeatedly)? – igal Nov 14 '17 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.