1

I recently switched from Windows 7 to Linux on my desktop PC. I've tried several distros: elementaryOS, Manjaro, Linux Mint with Cinnamon and currently with xfce, all of them properly installed and updated.

My issue, which was present on every distro I tried, was that anything animated was choppy and had tearing. Moving windows, scrolling a website, watching a video, etc. Currently I'm using Linux Mint with xfce, and after enabling Compton things have gone smoother, but videos (= Youtube) still have tearing. I'm not sure if Compton reduced video tearing slightly or if its just a placebo, but the tearing is definitely still there. My graphics card is ATI HD5770 and my other specs easily exceed the recommended specs for these OS's. With Windows 7 I didn't have these problems.

I've tried to enable the tearfree option but I'm not sure if I've got it enabled since the video tearing problem persists. To enable it, I cd'd into /usr/share/X11/xorg.conf.d/ and couldn't find the 20-radeon.conf file, so I created one and inserted:

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
    Option "DRI" "3"
    Option "AccelMethod" "glamor"
EndSection

and rebooted afterwards. No discernible effect on tearing. The directory did include files such as 10-amdgpu.conf and 20-amdgpu.conf (actually I don't remember for sure if the latter was there originally or if I created it, should such a file exist originally?), so I wonder if I should edit either of those? I tried inserting the above to those files with "Radeon" and "radeon" replaced as "AMDgpu" and "amdgpu", but that prevented me from booting into Mint. I had to use recovery mode to change the files back. I also tried the same without replacing "Radeon"/"radeon" as "AMDgpu"/"amdgpu", but I don't think that did anything. Is there an easy way to check if tearfree is enabled?

Running "lsmod | grep radeon" gives:

 radeon               1515520  37
 i2c_algo_bit           16384  1 radeon
 ttm                   102400  1 radeon
 drm_kms_helper        167936  1 radeon
 drm                   368640  6 radeon,ttm,drm_kms_helper

if that's any help.

My 10 year old business laptop with Lubuntu and a damaged screen plays videos smoother, so this is not cool. :/

Edit: I enabled "Override software rendering list" in Chrome's about://flags which reduced video tearing significantly. I'm still interested about the TearFree feature, or any other tips to make animations smoother.

Edit2: Never mind about the whole thing. I don't know if I made some mistake first time trying to enable tearfree, but now it's clear that adding the aforementioned lines to the 20-radeon.conf file almost completely cures tearing. If I turn the Chrome's "Override software rendering list" back to default (= disabled), slight tearing is visible on Youtube videos despite tearfree. So, enabling tearfree combined with the Chrome's override setting does it for me. I even disabled Compton because after enabling those two settings the effect it has on reducing tearing is minuscule, if any, and Compton has a drawback of creating a slight delay when e.g. moving a window. Hopefully this helps others with similar issues on AMD/ATI systems.

closed as off-topic by Jeff Schaller, jimmij, Stephen Rauch, GAD3R, roaima Nov 20 '17 at 0:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, jimmij, Stephen Rauch, GAD3R, roaima
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    If you have solved your own problem, the answer should go in the Answer box down below. – Jeff Schaller Nov 19 '17 at 14:35