2

I am using this macro to mark an email as read and archive it:

macro index,pager a ":set confirmappend=no
delete=yes\n<clear-flag>N<tag-prefix><save-message>=Archives\n<sync-mailbox>:set
confirmappend=yes delete=yes\n<next-undeleted>"

The macro works but only in the index. It does not work in pager despite the "pager" mention.

How can I have this macro work also in pager?

2 Answers 2

1

The answer is just that going to the pager remove the N flag of the email. So, of course, the macro doesn't work anymore...

0

You may have a macro pager a "whatever" defined after your mentioned macro. Please open the pager and press ?. Then have a look what a is doing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .